WordPress.org

Ready to get started?Download WordPress

Forums

Moving Blog to Main public_html directory (7 posts)

  1. kevincumbria
    Member
    Posted 5 years ago #

    When I set up my blog a month ago I put into into the main domain/blog directory.

    I now want the blog front page to be the main entry point when people type in the domain name rather than having to put in the /blog directory.

    I have copied all the files and sub directories from my /blog directory and the front page looks fine but when I try to access other pages via the tabs and other posts there is an error message. Pbviously there is some kind of mapping problem.

    How can I move all the relevant files and sub directories to the main public_html page and get the blog to recognise the posts and pages?

    TIA

  2. richarduk
    Member
    Posted 5 years ago #

    This might sound very obvious but the first thing to do is to check the links if they're hard coded in to the template.

    If all your links were to http://www.mysite.com/directory/etc. and now they're to http://www.mysite.com/etc. there will be problems.

    Another outside chance might be that you've used http://mysite.com on your old domain.com/directory site but http://www.mysite.com (or vice versa) on the new domain.com site

  3. kevincumbria
    Member
    Posted 5 years ago #

    Richard, I'check that out but I'm not sure sure how to redirect...

  4. richarduk
    Member
    Posted 5 years ago #

    Have you got a site link?

  5. Mossack Anme
    Member
    Posted 5 years ago #

    Have you edit the blog directory in your database. It will not change automatically if you only move your files.

    It's like WordPress address (URL) in your General Options menu. Or you can take an easier way like giving wordpress its own directory.

  6. kevincumbria
    Member
    Posted 5 years ago #

    Richard, the URL is http://web2andmore.net/bl;og but I see another user has asked the same question a few hours ago and it seems there is a fix at: http://wordpress.org/support/topic/293952?replies=5

    mossackanme, thanks for the heads up, I'll give that a go when I return from work tonight.

  7. kevincumbria
    Member
    Posted 5 years ago #

    Thanks, everything has gone smoothly - well I had to re-align a stack of posts with pix and point them to the right photograph, but wehat the hell, it's all up and running nice.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.