WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moved WordPress installation, uploading doesn't work anymore (10 posts)

  1. koesie10
    Member
    Posted 2 years ago #

    I moved my WordPress installation to another domain and now the uploading functions aren't working anymore. My first domain was: pontespaper.tk, and I changed it to pontesplanet.tk. In Settings->Media, my 'Store uploads in this folder' is set to '/home/my_user_name/domains/pontesplanet.tk/public_html/wp-content/uploads', but it still tries to upload to '/home/my_user_name/domains/pontespaper.tk/public_html/wp-content/uploads/Logo-Header.tmp'. Where do I have to change it as well, or is this a bug in WordPress? The permissions of wp-content/uploads are set on 777. I get the following error:

    Warning: touch() [function.touch]: Unable to create file /home/my_user_name/domains/pontespaper.tk/public_html/wp-content/uploads/Logo-Header.tmp because No such file or directory in /home/my_user_name/domains/pontesplanet.tk/public_html/wp-admin/includes/file.php on line 177

    The uploaded file could not be moved to /home/my_user_name/domains/pontesplanet.tk/public_html/wp-content/uploads/2012/04.

  2. peter achutha
    Member
    Posted 2 years ago #

    Wow what a long directory path... I have seen this problem before but cannot remember what caused it. But when I look at you file path names your WP is still pointing to the old domain.

    Before exporting your database in ýour old domain 'pontesppaper.tk' did you save under Settings > General
    1. WordPress Address (URL)
    2. Site Address (URL)
    to the new URL ...pontesplanet.tk and then export?

    In your Settings > General what are the links in these fields
    1. WordPress Address (URL)
    2. Site Address (URL)

    Set them to point to pontesplanet.tk. if that does not help your can try editing the database. Go to phpmyadmin and find wp_options table. In that table there is a field called 'siteurl' what link does it show? it should be ...pontesplanet.tk

    see if that helps

  3. koesie10
    Member
    Posted 2 years ago #

    WordPress Address (URL) is set to http://pontesplanet.tk and Site Address too. In phpmyadmin the table siteurl says 'http://pontesplanet.tk'. I've searched through the whole table wp_options and it said only once pontespaper.tk, which was in a plugin, and I changed that one. I searched through my whole database, and nowhere was pontespaper.tk, except for where it said guid in the table wp_posts. Also, Core Control just says that ABSURL is '/home/my_user_name/domains/pontesplanet.tk/public_html/', WP_CONTENT_DIR is '/home/my_user_name/domains/pontesplanet.tk/public_html/wp-content' and WP_PLUGIN_DIR is '/home/my_user_name/domains/pontesplanet.tk/public_html/wp-content/plugins'.
    I just changed the guids to pontesplanet.tk too, by using Velvet Blues Update URLs. I really don't know how to solve this problem, it's just showing two different paths.

  4. peter achutha
    Member
    Posted 2 years ago #

    Firstly permission should be set to either 755 or (I think) 644. Leave them at 755 or you may get other errors not related to the current situation.

    There is one more possibility. I just had a look at your site both site look ok.

    There is one more thing you can check and that is, is there a config or set up option for your theme. Looks like you are you are using a magazine theme. Does it have a set or configuration section. It is possible that (I am guessing) that you copied over the plugins and themes and they were not installed fresh. If there is a config or set up in one of your plugins or theme it would have carried over the old domain path. Try editing it to the new path. Sometimes re-installing a plugin or theme will not clear the config or set up. If this is the case you will need to find them and change them to the new path.

    I hope this helps.

  5. koesie10
    Member
    Posted 2 years ago #

    The permissions of wp-content/uploads are set to 755, but first they were 777, so I don't think that is possible. Also, there are no settings in the theme of a path. And I don't think that could be the case, because all uploading doesn't work, media, plugins and all that kind of stuff, it just has the wrong path. I searched for it in a lot of files, but nowhere that path was defined.

  6. peter achutha
    Member
    Posted 2 years ago #

    Did you try going to Settings > Media and set the field under Uploading Files section

    Field: 'Full URL path to files' with your new path
    http://pontesplanet.tk/wp-content/uploads

  7. koesie10
    Member
    Posted 2 years ago #

    I tried it, but it doesn't change anything for the uploading. The error is still:

    Warning: touch() [function.touch]: Unable to create file /home/my_user_name/domains/pontespaper.tk/public_html/wp-content/uploads/Blauwe-heuvels.tmp because No such file or directory in /home/my_user_name/domains/pontesplanet.tk/public_html/wp-admin/includes/file.php on line 177
    “Blauwe heuvels.jpg” has failed to upload due to an error
    The uploaded file could not be moved to /home/my_user_name/domains/pontesplanet.tk/public_html/wp-content/uploads/2012/04.
  8. koesie10
    Member
    Posted 2 years ago #

    I just found the solution. In wp-config.php the variable 'WP_TEMP_DIR' was set to the wrong path. Now uploading works again. Thanks for your help.

  9. Morgan Feeney
    Member
    Posted 1 year ago #

    Hurrahhh!!! Thanks @koesie10, I just had the same issue, you saved me a ton of research.

  10. awhittle
    Member
    Posted 1 year ago #

    koesie10 : your a legend

    I just found the solution. In wp-config.php the variable 'WP_TEMP_DIR' was set to the wrong path.

    Thanks, your a star

Topic Closed

This topic has been closed to new replies.

About this Topic