WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moved wordpress installation, but images still uploads to old location! (7 posts)

  1. xelium
    Member
    Posted 5 years ago #

    Hi There,

    Moved from http://www.example.com to http://www.example.com/blog

    Everything works except the image uploader.

    Images still uploads to http://www.example.com/wp-content/upload and not to the http://www.example.com/blog/wp-content/upload

    How do i fix this?

    Thanks a Bunch!

  2. Saurus
    Member
    Posted 5 years ago #

    Read the codez faq on moving your url.

  3. xelium
    Member
    Posted 5 years ago #

    Hi Saurus,

    Thanks for taking the time to reply.

    I have read and complied with every step. The issue is that every new picture that i upload goes into the old directory.

    Yet strangely, the IMG url in the actual post points to the image file that is supposed to be uploaded in the new dir. Since it does not exist, i get a broken IMG file.

    I have keyed in the correct site URL and blog URL under settings. Is there anything i'm missing out? How can i fix this?

  4. micharo
    Member
    Posted 5 years ago #

    Hi,

    Check
    Settings -> Miscellaneous in the admin. There you can change the upload url.

    Perhaps this helps!

    Michael

  5. xelium
    Member
    Posted 5 years ago #

    Hi Mike,

    Thanks!

  6. David Jones
    Member
    Posted 5 years ago #

    I had this very same problem and Nick from wordpress wanted a copy of my XML file and I sent him a screen capture?

    But yet none of the actual files moved their were all 301 remote server file error.

    Here is the screen capture.
    http://www.robertdall.com/wordpress_error.png

    I haven't heard back from Nick at wordpress but I am not sure if going into my Misc will change something that is isn't on my site.

    Can any experienced members say if I am doing something wrong?

  7. Saurus
    Member
    Posted 5 years ago #

    Impossible to say if you did something wrong - because you haven't said what you did. The reference to the Misc. on the daskboard only shows what directory structure uploads should go to. If you have it set to "month and year" and that structure doesn't exist - there is no place for new files to go. Best is to UNcheck that option and use the default /uploads folder so everything goes there. You can move anything that is in the old folder there from ftp.

Topic Closed

This topic has been closed to new replies.

About this Topic