WordPress.org

Ready to get started?Download WordPress

Forums

Moved WordPress, error on new posts (8 posts)

  1. threeboy
    Member
    Posted 7 years ago #

    Hello,

    I recently switched hosts - and I re-uploaded the script to the new host and imported the backed up database.

    When I posted a post for the first time I was presented with an error. A post was posted but for some reason it has an ID of 0, and I can't edit it.

    When I try to post again I get this error:

    WordPress database error: [Duplicate entry '0' for key 1]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES ('0','_encloseme','1')

    Warning: Cannot modify header information - headers already sent by (output started at /home/virtual/site328/fst/var/www/html/wp-includes/wp-db.php:104) in /home/virtual/site328/fst/var/www/html/wp-includes/pluggable-functions.php on line 272

  2. threeboy
    Member
    Posted 7 years ago #

    Same thing happens to comments.

    phpmyadmin also gives these errors

    ------------------------------------

    Error
    The additional Features for working with linked Tables have been
    deactivated. To find out why click here.

    ---------------AND-----------------

    PMA Database ... not OK[ Documentation ]
    General relation features Disabled

  3. jer2eydevil88
    Member
    Posted 7 years ago #

    What version of wordpress were you using before? Have you tried following the instructions for upgrading to a newer veresion of WordPress?

  4. threeboy
    Member
    Posted 7 years ago #

    I think we were using 2.0.1 - I ran the upgrader, and it said everything was fine.

    I really think its' an SQL problem - something to do with the table i imported having the general relation features disable as well as the linked tables being deactivated.

    ...how do i get those proper again?

  5. threeboy
    Member
    Posted 7 years ago #

    I know the problem - when dumping the SQL from my old host I exported using 3.2 compatibility - since the SQL was downgraded it disabled the auto-incriment on the tables.

    Anyone know the SQL queries to run that will enable auto-incriment for the proper tables?

  6. lbeth
    Member
    Posted 7 years ago #

    i don't know the sql to run, but if you want to go in php myadmin and edit the tables, i found http://codex.wordpress.org/Database_Description#Table:_wp_categories in the codex, and that told me where to turn on auto increment.

    i was having the same issue, and it appears to have worked for me.

  7. threeboy
    Member
    Posted 7 years ago #

    anyone know how to enable auto-incrimenting in phpmyadmin?

  8. threeboy
    Member
    Posted 7 years ago #

    figiured it out - that workd BIG THANKS lbeth!!!

Topic Closed

This topic has been closed to new replies.

About this Topic