WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moved WordPress but lost special characters (12 posts)

  1. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    Hi all,

    I moved WordPress in the way listed in the Codex without any special problems, but now - when everything is running - all special characters for my language (Swedish that is, åäö) are lost and all I see instead of them is a question mark.

    In action: http://www.tdh.se

    The top post was made after the move and displays åäö as it should.

    Help?

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Try the following:
    Using the exported database, open in it Notepad++
    http://notepad-plus.sourceforge.net/uk/download.php

    'Select All'
    Change the character encoding to UTF-8 (Format menu it's in)
    Save

    Import that into the database.

    See what happens ?

  3. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    Didn't help.

    Maybe I should do a search and replace for all the åäö's and ÅÄÖ's to html-code in the sql-file?

  4. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    Ok, so I browsed the imported database on the new server. It says it's "latin1_swedish_ci" wich sounds about right, and when I'm looking at the posts in MyAdmin I can see åäö so it hasn't lost them in the exportion or anything.

    Maybe it's a server setting?

  5. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    Any other suggestions?

  6. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    I'm really stuck here guys... Any help or suggestions?

  7. editor
    Member
    Posted 8 years ago #

    I had (I have, actually...) a similar problem when I copy my database to my test site. I think it's a problem of the hosting provider, in terms of upload capabilities, especially if have to import a big database. Try the alternative upload option, suggested by Podz: a copy and paste of single chunks of your database, from within phpMyAdmin. Full instructions here:

    http://www.tamba2.org.uk/wordpress/restore/

  8. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    I'll take a look at it, but I'm pretty sure that it isn't a size issue since it all loads into the database with the right characters.

    I have now eliminated the possibility that it is a server issue. This can also be seen as it works perfectly fine if I post new messages after the restor - old posts get question marks instead of åäö while new gets the right characters, and it all looks the same in the database.

    Man, is this annoying me or what!

  9. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    Ok. Tried the above suggestion out of pure frustration. It didn't help, as expected. (No errors and everything loaded into the database but åäö are questionmarks on the website but in plain text in the database.)

    However, browsing the database made me realize this:

    This is a new post, where åäö works perfectly fine on the site - it displays like this online: åäö (gemener) samt ÅÄÖ (versaler).

    In the database it looks like this: åäö (gemener) samt ÅÄÖ (versaler).

    åäö and ÅÄÖ is not in plain text on new posts (after the move), but old posts show them in plain text!

    What to do? Help, please!

  10. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    I managed to solve this. I'm not entirely certain, but it seems that my old server had a fairly old MySQL-database and therefor I needed to make sure I imported it with latin1, not UTF-8 that is specified in the codex.

    Of course, when imported I changed it to UTF-8 because it's, well, better.

  11. editor
    Member
    Posted 8 years ago #

    I see everything works fine now! I will check for my hosting provider database...

  12. Thord Daniel Hedengren
    Member
    Posted 8 years ago #

    Good luck and let me know if I can help out in any way.

Topic Closed

This topic has been closed to new replies.

About this Topic