WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moved to new host, now theme is not working (4 posts)

  1. tiggsy
    Member
    Posted 5 years ago #

    I had to move hosts, so i moved the database files and the flat files over to the new one. At first, it seemed to be working fine, but the other user could not log in, he kept getting a 403. Eventually i think i fixed that, just by allowing his ip specifically in all the folders with a .htaccess file. However, now he can get to the site ok, but the stylesheet isn't working. I tried changing the theme to another and back, but neither theme seemed to take effect. In fact, the style for the admin isn't even working, which makes the admin area quite difficult to use.

  2. jberghem
    Member
    Posted 5 years ago #

    sounds like a CHMOD problem. Check the read, write & execute permissions of the WordPress folders on the server.

  3. tiggsy
    Member
    Posted 5 years ago #

    More information: it's version 2.5.1 running on an addon domain on a cpanel host. It's linux/apache and mod_security is not installed.

    -I don't know what VHOST is, so can't specify it.
    -blog is in the root directory for this domain
    -This is the error log:
    [Mon Sep 22 08:23:13 2008] [error] [client 65.29.161.242] File does not exist: /home/tiggsy/public_html/ramsaysround.com/404.shtml
    [Mon Sep 22 08:23:13 2008] [error] [client 65.29.161.242] File does not exist: /home/tiggsy/public_html/ramsaysround.com/custom
    [Mon Sep 22 08:21:56 2008] [error] [client 92.235.216.91] File does not exist: /home/tiggsy/public_html/ramsaysround.com/403.shtml, referer: http://www.ramsaysround.com/
    [Mon Sep 22 08:21:56 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-content/themes/munros/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/
    [Mon Sep 22 08:21:10 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-content/themes/munros/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/
    [Mon Sep 22 08:21:07 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-content/themes/munros/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/
    [Mon Sep 22 08:21:03 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-admin/css/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/wp-admin/
    [Mon Sep 22 08:21:03 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-includes/js/jquery/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/wp-admin/
    [Mon Sep 22 08:21:02 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-admin/js/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/wp-admin/
    [Mon Sep 22 08:21:02 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-includes/js/thickbox/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/wp-admin/
    [Mon Sep 22 08:21:02 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-includes/js/jquery/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/wp-admin/
    [Mon Sep 22 08:21:02 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-admin/css/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/wp-admin/
    [Mon Sep 22 08:21:02 2008] [crit] [client 92.235.216.91] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-admin/css/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/wp-admin/
    [Mon Sep 22 08:19:58 2008] [crit] [client 90.240.225.121] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-content/themes/munros/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/disclaimer/
    [Mon Sep 22 08:19:10 2008] [crit] [client 90.240.225.121] (13)Permission denied: /home/tiggsy/public_html/ramsaysround.com/wp-content/themes/munros/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://www.ramsaysround.com/useful-contacts/
    - there was no browser error
    - i dont know how to check wp_blogs, wp_users and wp_site
    - version 2.5.1, dont know SVN checkin number, dont know anything about any snapshot
    - only plugins used are in place, turning them off has no effect
    - it's apache/linux, i don't know the answers to the other stuff
    - i'm using firefox on linux, other user is using ie on windows
    - just load it. it's supposed to be 800px centered... and the sidebar is currently at the bottom instead of at the side, all the pretties are gone, as well
    - site is ramsaysround.com

    i read the readme. it didn't have any relevant content that i could see.

    the mysql settings in wp_config are fine.

    last thing i did was to change the folders to 0755 and the files to 0644 - this was one of the things that came up when i was trying to work out why the other user was getting a 403.

    **another bug which occurred when i first moved it over is that it would not find the images in the UPLOADS folder (kept getting 404 even though they were actually there), so i had to move them all to the root folder and change all the urls in the pages. Don't know if this is related...

  4. tiggsy
    Member
    Posted 5 years ago #

    It's now working.

    In case anyone else gets this problem, what i did was delete all the files (not the database) and upload a fresh copy.

Topic Closed

This topic has been closed to new replies.

About this Topic