WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moved to new host, now pages do not display (9 posts)

  1. starfishtrainers
    Member
    Posted 2 years ago #

    Just moved a WP installation,(same domain name, new host) and the front page shows just fine, the log in even works fine.

    Site can be found at : http://2011.yaegercpareview.com/

    The permalinks do not display/work. We are using pretty permalinks "/%postname%/", and no joy. We get a 404 error.

    Even the ugly permalinks do not work. The "AUD" nav is to p=5, and it does not respond.

    The only diff between this install and the old one, is this one is running on Windows 2008 (with updates) with IIS 7.5.

    We have another WP site created on this box and permalinks work fine, so I don't think Windows and IIS are the issue.

    The 2011. is a sub-domain, could that be the issue?

    Any ideas?

    Thanks for any help.

  2. starfishtrainers
    Member
    Posted 2 years ago #

    As an aside, even newly created pages (post move) get the 404 error.

    Frustrating.

  3. Josh (WP Edit)
    Member
    Posted 2 years ago #

    Hmmm... try going to your permalinks page in your admin... select default and save. Then reselect your permalink option and save again.

  4. starfishtrainers
    Member
    Posted 2 years ago #

    No joy. But, I did learn something.

    When I use default permalinks, the navigation works, and everything works fine.

    When I put back the custom "/%postname%/" value, 404 error.

    Could this be an IIS issue?

  5. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

  6. Josh (WP Edit)
    Member
    Posted 2 years ago #

    Thanks cubecolour... I love how much I am learning from these forums :)

  7. starfishtrainers
    Member
    Posted 2 years ago #

    NICE! The addition of index.php/ to the Custom Permalink string worked.

    Now, I will see if I can pretty things up and load the URL Rewrite Module and fix it right.

    Thanks for the help.

  8. starfishtrainers
    Member
    Posted 2 years ago #

    New issue.

    I installed the URL Rewrite Module, and have updated my web.config file.

    Now, my url appears as follows...

    http://2011.yaegercpareview.com/index.php/non-members/?wlfrom=%2Findex.php%2Faud%2F

    When I just used the /index.php/ addition too the Custom Permakink structure, the URL was : http://2011.yaegercpareview.com/index.php/aud/

    Any idea how to get this format back?

    I have backed out the changes and rebooted the system, URL still messed up.

  9. starfishtrainers
    Member
    Posted 2 years ago #

    Appears new issue is only with users non-members.

    I think I can live with this.

Topic Closed

This topic has been closed to new replies.

About this Topic