WordPress.org

Ready to get started?Download WordPress

Forums

Moved to dedicated lynix server - need to update database, can't log-in (3 posts)

  1. lagunaalbums
    Member
    Posted 6 years ago #

    I recently changed my database from Godaddy.com to my own dedicated lynix server at Singlehop.com.

    I need to change the database but have no idea how to do it properly.

    I changed the database host to "localhost" in teh wp-config.php file. I get teh following message:

    "
    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums."

    How can I change the password.

    I have c-panel and dreamweaver but no way to access the WP-admin online.

    Here is the URL:

    http://www.studiowork.com/wordpress

    Thank You!

    Here is the wp_config settings:

    "<?php
    // ** MySQL settings ** //
    define('DB_NAME', 'stu0718704485106'); // The name of the database
    define('DB_USER', 'stu0718704485106'); // Your MySQL stu0718704485106
    define('DB_PASSWORD', 'xxx'); // ...and xxx
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>"

  2. whooami
    Member
    Posted 6 years ago #

    lagunaalbums,

    I got your email.

  3. lagunaalbums
    Member
    Posted 6 years ago #

    I was able to solve this problem with the combined tech support of Godaddy and Singlehop.

    The solution involved logging into my Godaddy account and exporting the database they created.

    Then I imported it to the Singlehop server using c-panel.

    Then the user name had to be changed by the server administrator.

    Good times!

    I should acknowledge the extremely helpful people at Singlehop. They are the reason I chose their hosting company for my server.

Topic Closed

This topic has been closed to new replies.

About this Topic