WordPress.org

Ready to get started?Download WordPress

Forums

Moved site to new server, now doesn't display (23 posts)

  1. glendapizz
    Member
    Posted 5 years ago #

    Moved site to new server, new domain name. changed active themes function.php to reflect new domain. can get into wp-admin and login.

    when view site, nothing comes up.

  2. MichaelH
    Member
    Posted 5 years ago #

    changed active themes function.php to reflect new domain

    Not too sure what you would have needed to change there...

    If you can change to the WordPress Default theme and then can see site, might try reuploading set of files for your theme.

    Also if necessary use this plugin http://wordpress.org/extend/plugins/search-and-replace/ to make sure new domain is used everywhere.

  3. MichaelH
    Member
    Posted 5 years ago #

    Oh and update your permalinks via Administration > Settings > Permalinks

  4. glendapizz
    Member
    Posted 5 years ago #

    Thanks. Running wp 2.5 on windows server.

    Added update_option('siteurl','http://www.allaboutsmiles.us');
    update_option('home','http://www.allaboutsmiles.us');
    to wp-content\themes\medical-blog-10\functions.php according to wordpress support.

    permalinks is updated. all links refer to new domain. getting http error 500. my hosting company, verio, suggests that the index.php file is wrong. the index.php file in the root is:
    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>
    This wordpress site was created by someone else on another server with a different domain name. How does the index.php file get created. perhaps this is the problem.

  5. MichaelH
    Member
    Posted 5 years ago #

    If WordPress is in the web-root folder (where wp-admin, wp-content, wp-includes reside) then that looks like the proper index.php.

    You shouldn't need to update those settings if your Settings->General WordPress and Blog address URLs are correct.

  6. glendapizz
    Member
    Posted 5 years ago #

    WordPress is in the web-root folder (where wp-admin, wp-content, wp-includes reside.

    Settings->General WordPress and Blog address URLs are correct.

    am at a loss. any other suggestions

  7. MichaelH
    Member
    Posted 5 years ago #

    So your web-root folder should have a file called index.php and that file should be this:

    <?php
    /**
     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     *
     * @package WordPress
     */
    
    /**
     * Tells WordPress to load the WordPress theme and output it.
     *
     * @var bool
     */
    define('WP_USE_THEMES', true);
    
    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');
    ?>

    Only other thing I can come up with is that your index documents aren't specified, which might require these;

    Solution 1
    If allowed by your host, putting this in an .htaccess file will solve the problem:
    DirectoryIndex index.html index.htm index.php

    Solution 2
    Some hosts allow you to make a change, via their hosting control panel, to the DirectoryIndex. It's typically described as Indexes or Index documents, but may also require you to type something like
    DirectoryIndex index.html index.htm index.php
    or specify index.php as an index type file.

    Solution 3
    Instruct Apache to treat index.php as an index file. If you own the server, or have access to the http.conf file, simply modify the DirectoryIndex line in httpd.conf to:
    DirectoryIndex index.html index.htm index.php

    Solution 4
    Contact your host

  8. glendapizz
    Member
    Posted 5 years ago #

    This is my index.php file:
    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

    index.php has already been set to top of index list.

    My host, Verio, said it was something wrong with the wordpress php's. They actually do not know what is the problem and won't help as it's a third party.

    At the time, not knowing whether to install wordpress or just copy when moving from one host to another, I ftp'd the zip file to new host web root, unzipped on the host, moved everything up to root as wanted to use http://www.allaboutsmiles.us, created the mysql DB and did create the tables. the database name had to change as it is required by Verio. Changed this in wp-config.php. changed the dbhost to define('DB_HOST', 'mysql-g11a.mysqldbserver.com'); left the secret-key alone.

    I can login to http://www.allaboutsmiles.us/wp-admin and modify things and the wp database gets updated so assume the setting are correct.

    Verio has a copy of wordpress and an auto install feature. I did try it, but it said database already existed and I cancelled out.

    All links are correct too.

    Here's something never mentioned to you. When in wp-admin, Dashboard, Manage, Pages - can edit pages, but when time to view, View This Page - nothing comes up just like when trying to view the website.

    Any thoughts?

  9. MichaelH
    Member
    Posted 5 years ago #

    Yes, deactivate all plugins, change to the WordPress Default theme and see if that resolves the problem.

  10. glendapizz
    Member
    Posted 5 years ago #

    When you change to the default theme, do you lose everything that's been done in the previously selected theme.

  11. MichaelH
    Member
    Posted 5 years ago #

    No.

    But recommend you read and execute WordPress Backups.

  12. glendapizz
    Member
    Posted 5 years ago #

    Ran the backups.

    Deactivated all plug ins. Changed to default theme.

    Nothing comes up. created new page, still get blank.

    Currently on wp 2.5, should i try the upgrade to 2.7?

  13. MichaelH
    Member
    Posted 5 years ago #

    Upgrading is not a bad idea just because you will get a new set of files uploaded to your host. And since you have a files and database backup, might be a good time to upgrade. Of course you may have some theme issues to fix...

    If you have an .htaccess file and rename it temporarily does that fix the problem?

  14. glendapizz
    Member
    Posted 5 years ago #

    do not have .htaccess

  15. MichaelH
    Member
    Posted 5 years ago #

    Might check to see if you have any log files that are might show errors.

    Also check with your host for any ideas.

  16. glendapizz
    Member
    Posted 5 years ago #

    what kind of write permissions does wp need?

  17. MichaelH
    Member
    Posted 5 years ago #

    Hardening WordPress says 755 for directories and 644 for files, mileage may vary...

  18. glendapizz
    Member
    Posted 5 years ago #

    thanks.

    I'm running on a windows server

    just found out about and enabled the mod_rewrite Apache module.

    pages are still blank though. is there anything i should do? Now it seems i can have a .htaccess file.

  19. glendapizz
    Member
    Posted 5 years ago #

    wp-cron.php is getting the http 500 more than index.php.

  20. glendapizz
    Member
    Posted 5 years ago #

    how can't get into wp-admin. getting access violations

  21. glendapizz
    Member
    Posted 5 years ago #

    Very weird. after reading posts, it seems this error is due to excess traffic on the host using isapi. can wp run with php cgi?

  22. joshri
    Member
    Posted 5 years ago #

    did you have any luck resolving this issue, glendapizz? i'm having the same issue (and have the same unhelpful host).

  23. g33kg0dd3ss
    Member
    Posted 5 years ago #

    I'm working on a client's site, also hosted with Verio, and I ran into this exact same issue.

    I added an echo to the top of index.php, so I could tell that the file itself is being loaded. I narrowed the problem down to this line:
    require('./wp-blog-header.php');

    I changed it to this:
    require('wp-blog-header.php');
    ...(removing the "./")and now it works!

    I'm not sure how it will stand up to future automatic upgrades, but thankfully it's such a minor change that having to go back in later and do it again is trivial, at best.

    Hope this helps! :)

Topic Closed

This topic has been closed to new replies.

About this Topic