WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moved Site: now getting Error establishing a database connection (8 posts)

  1. KristyO
    Member
    Posted 1 year ago #

    I'm trying to move a blog I had at one web address to another e commerce site I have into a folder newsite.com/blog

    On that site I changed where the site was located at to newsite.com/blog

    I was told I could backup the database, change all links from "oldsite.com/" to "newsite.com/blog/" then import the .sql into a new database I set up on newsite's phpAdmin, then I changed all of the info in the wp-config.php file

    Now I go to newsite.com/blog and I get the error: Error establishing a database connection. What do I do? What did I do wrong... please help. I'm am such a rookie when it comes to this.

    Thanks you!

  2. govpatel
    Member
    Posted 1 year ago #

    Recheck your database info in your wp-config.php file

  3. KristyO
    Member
    Posted 1 year ago #

    Ok, i had the used name wrong in the file.

    Now that I got that far I'm getting a page not found error?

    And I can not log into the dashboard... What do I do?

    Thank you soo much!

  4. KristyO
    Member
    Posted 1 year ago #

    I also went in and checked in phpMyAdmin and checked to make sure that the site url was correct and it was...

    I'm trying to move from http://www.whosyourmoondoggie.com to http://www.moondoggieinc.com/blog

    I'm really at a loss of what to do...

    KristyO

  5. KristyO
    Member
    Posted 1 year ago #

    also when I got to http://www.moondoggieinc.com/blog/wp-login.php and try to login it brings me back to the old site still...

  6. You need to correctly change URLs in the database and reset permalinks. See Moving WordPress « WordPress Codex and How to Move WordPress to New Domain or Location » My Digital Life

  7. KristyO
    Member
    Posted 1 year ago #

    Ok I went through that and used the code to do the find and replace on my database and now I can log in, see the homepage, but all the posts give me 404 errors...

    What now?

  8. Shekhar
    Member
    Posted 1 year ago #

    Go to Permalink Settings and click on save changes.

Topic Closed

This topic has been closed to new replies.

About this Topic