WordPress.org

Ready to get started?Download WordPress

Forums

Moved renamed wp-content folder new media doesn't upload now (4 posts)

  1. James Laws
    The WP Ninjas
    Posted 2 years ago #

    So I've renamed my wp-content folder to "r" for resources. I serve a lot more than just the themes and plugins from here. I've defined the WP_CONTENT_DIR and WP_CONTENT_URL in my wp-config.php and almost everything works fine.

    Themes and plugins load and all old images are served up from the r/uploads directory just fine.

    My problem is when I try to upload an image it creates the entry in the media manager but it doesn't actually upload the image.

    Any ideas why this might be?

  2. James Laws
    The WP Ninjas
    Posted 2 years ago #

    Just to provide more info...

    I have a mirror of this site on my localhost and it uploads images just fine without issue.

    I'm assuming that this means it has something to do with server configuration but I can't for the life of me figure out what would be causing this behavior.

  3. What's it showing in /wp-admin/options-media.php ?

  4. James Laws
    The WP Ninjas
    Posted 2 years ago #

    New Information.

    When I comment out the constants and change everything back to wp-content it uploads fine.

    I noticed that it created the new date based folders as the main apache user with permissions of 777 and not the user I set up for accessing the site.

    I think this is an issue of permissions that are now somehow working differently and I need to explore that a little further.

Topic Closed

This topic has been closed to new replies.

About this Topic