WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moved index.php to Root but Permanlinks Won't Update (3 posts)

  1. Velanche
    Member
    Posted 8 years ago #

    The above post kinda/sorta says it in a nutshell.

    I've moved both the index.php and .htaccess per the instructions in the Codex. My core WordPress files are in a /wordpress subdirectory.

    The site comes up fine, but when I tried updating the Permalinks, I get a message that says "You should update .htaccess now." Then when I went into the Files section of the Manage tab in the admin panel, I get an error when attempting to access that .htaccess file...

    Oops, no such file exists! Double check the name and try again, merci.

    This is part of my .htaccess code...


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /index.php/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php/index.php [L]
    </IfModule>

    # END WordPress

    By the way, the file (for now) has permissions of 775, but I want to get it back to 755 when done.

    I'd appreciate the help; thanks!
    Velanche

  2. Samuel B
    moderator
    Posted 8 years ago #

    Delete or rename any current .htaccess
    Try the old fashioned way. Open Notepad - hit the space bar once - save it as whatever.txt
    Upload it - rename it to .htaccess and CHMOD to 666.
    Update pemalinks.
    Go back and CHMOD .htaccess to 644 for security.
    Never have a file with 775 or 755.
    Only folders should be 755.

  3. Velanche
    Member
    Posted 8 years ago #

    Thanks for the help.

    The actual problem was that things broke down when I've tried putting in the index.php at the end of the root address in the WordPress Options area. I wanted to do this while fixing up the site, but removing the file name has permalinks working again.

    It's the little things. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic