WordPress.org

Ready to get started?Download WordPress

Forums

Moved IIS to Apache: Textile error. (2 posts)

  1. Michael Heilemann
    Member
    Posted 11 years ago #

    After having my site moved from an IIS server to an Apache server, primarily to fix the cookie problem. Textile no longer works!
    If I uncomment the include textile line in b2vars.php I get this:
    Warning: main() [function.main]: open_basedir restriction in effect. File(/usr/local/lib/php/textile.php) is not within the allowed path(s): (/STORE/binarybonsai_com) in /STORE/binarybonsai_com/public_html/b2-include/b2vars.php on line 275
    Warning: main(textile.php) [function.main]: failed to create stream: Operation not permitted in /STORE/binarybonsai_com/public_html/b2-include/b2vars.php on line 275
    Warning: main() [function.main]: Failed opening 'textile.php' for inclusion (include_path='.:/usr/local/lib/php') in /STORE/binarybonsai_com/public_html/b2-include/b2vars.php on line 275
    Huh?!

  2. Michael Heilemann
    Member
    Posted 11 years ago #

    I had one of my friends help me solve this. I'll post it here for the archives:
    In b2vars.php where you normally turn on textile, mine looks like this:

    add_filter('all', 'wptexturize');
    // add_filter('the_content', 'wpautop');
    add_filter('comment_text', 'wpautop');
    // Uncomment the following for Textile support
    // include_once('textile.php');
    $res = include_once('/STORE/binarybonsai_com/public_html/b2-include/textile.php');
    if(!res) {
    if( !in_array('/STORE/binarybonsai_com/public_html/b2-include/textile.php', get_included_files()) ) {
    echo "The file '/STORE/binarybonsai_com/public_html/b2-include/textile.php' does not exists";
    exit(1);
    }
    }
    add_filter('the_content', 'textile');
    // There is some duplication of effore so textile.php really should be tweaked to eliminate that.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.