WordPress.org

Ready to get started?Download WordPress

Forums

GD bbPress Attachments
[resolved] Move from U Buddypress Forum Attachments to GD bbPress Attachments (7 posts)

  1. gemonon
    Member
    Posted 1 year ago #

    Hey there,

    has anybody here successfully moved from
    https://wordpress.org/plugins/u-buddypress-forum-attachment/

    to GD bbPress Attachments?

    I am trying to move from buddypress legacy group forums to the new bbpress buddypress forums and U BuddyPress Forum Attachments are lost that way :/

    So I would need to somehow transform the database entries for attachments from one software to another but don't have a clue right now how to do this...

    Any ideas or experiences?

    Warm regards,
    Georg

    http://wordpress.org/plugins/gd-bbpress-attachments/

  2. Milan Petrovic
    Member
    Plugin Author

    Posted 11 months ago #

    U BuddyPress Forum Attachments is not compatible with WordPress bbPress plugin, it was made for standalone bbPress 1.0. Converting attachments from it to my plugin is very complicated, and I don't plan on implementing it.

  3. mrjarbenne
    Member
    Posted 9 months ago #

    We were stuck in bbpress 1.o on our BuddyPress install because of the U Forum Attachments plugin, so we had this built so we could move to bbPress 2.x and the GD Forum Attachments plugin.

    https://github.com/hwdsbcommons/u-bp-forum-attachment-migration

    Worked like a charm for us.

  4. gemonon
    Member
    Posted 9 months ago #

    Wow, thanks a lot. Worked for me as well and made me very happy since I was now able to upgrade buddypress without any issues :D

    Just one thing to note, as I found out afterwards, you need to keep U Forum Attachments plugin installed and active for the "Legacy Attachments" to continue working - otherwise you will receive a "file not found" error.

    Might be worth mentioning in the readme :)

    All the best and again, thank you sooo very much!

  5. mrjarbenne
    Member
    Posted 9 months ago #

    That's odd. That hasn't been our experience. I've deactivated the U forum plugin and the files are still there.

    Is it a specific file type you are having issues with?

  6. gemonon
    Member
    Posted 9 months ago #

    Hey there,

    I investigated my previous steps and redid it all. The results below. For now for the lazy, the process works and works well - I am really grateful for the plugin! Doing everything like in the readme works great!

    However, I did not stop there ;)

    Deactivating the old U BuddyPress Forum Attachment plugin indeed as you suggested works.

    However, deinstalling the old U BuddyPress Forum Attachment plugin leads to file not found errors. Maybe the readme could advise against this as for a non-programmer like me, removing and deactivating a plugin were nearly identical ;)

    Reinstalling the old U BuddyPress Forum Attachment plugin afterwards makes it even worse. After clicking on Download the page reloads without an error but no file is served :/

    Just for completion - deactivating your migration plugin is also not a good idea, since then the attachments vanish again ;) Maybe it could be mentioned in the readme that this needs to be permanently active?

    In any case, wonderful work - really, really appreciated and works really well <3

  7. mrjarbenne
    Member
    Posted 9 months ago #

    I hope in testing all this out you haven't lost access to you files. It sounds like your testing took you down a dark road ;)

    I'm going to assume from the last statement that you are up and running. I"ll let the developer know your feedback.

    Cheers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic