WordPress.org

Ready to get started?Download WordPress

Forums

Share Buttons by AddThis
[resolved] Most recent update # of likes incorrect if not viewing individual post (12 posts)

  1. adawgz
    Member
    Posted 1 year ago #

    I have fully updated wordpress, and when I installed your most recent update for this plugin, an error has now arisen on the homepage or on a category page where multiple posts are listed. Before each post would show it's correct number of likes etc. but it now shows the same number of likes for each post listed on the noted pages (which I think means it is showing the number of likes for the category URL, the homepage URL, etc). However, when you go to an individual post, the number of likes is still correct.

    http://wordpress.org/extend/plugins/addthis/

  2. Ken
    Member
    Posted 1 year ago #

    I'm having the issue right after upgrading to 3.0.4. Count is incorrect on home page but OK in single post.

    Please help

  3. adawgz
    Member
    Posted 1 year ago #

    As Ken noted, this is with regards to version 3.0.4.

  4. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    Thanks for the heads up. We are noticing that in certain themes, count is having issue. Working on it now.

  5. adawgz
    Member
    Posted 1 year ago #

    For me it isn't working in Twenty Eleven.

  6. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    @adawgz: Can I have a link to your site?

  7. Ken
    Member
    Posted 1 year ago #

    You can check it here. Sawpanse.Com

  8. TraciBunkers
    Member
    Posted 1 year ago #

    I'm having the same issue--but only on the buttons on the top of my posts. The ones at the bottom, where it only shows the number of addthis shares, is different.

    I have custom buttons for the top, but not for the bottom.When I switch the top so that they aren't custom, the problem goes away.

    Here's my custom code:

    <div class="addthis_toolbox addthis_default_style">
        <a class="addthis_button_facebook_like" fb:like:layout="button_count"></a>
    <a class="addthis_button_tweet"></a>
    <a class="addthis_button_google_plusone" g:plusone:size="medium"></a>
    <a class="addthis_button_pinterest_pinit" pi:pinit:layout="horizontal"></a>
    <a class="addthis_counter addthis_pill_style"></a>
    </div>

    https://www.tracibunkers.com/blog/

  9. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    We are working on a fix, and an intermediate build is available at our development branch ( http://downloads.wordpress.org/plugin/addthis.zip ) . I suggest you to try it out, and let me know if the problem exist.

  10. Ken
    Member
    Posted 1 year ago #

    Thanks @srihith.v, this fixed it. ^

  11. bluantinoo
    Member
    Posted 1 year ago #

    I have a similar problem, posted here:
    http://wordpress.org/support/topic/no-images-and-js-error?replies=2

    I tried the dev branch but nothing changed :(

  12. TraciBunkers
    Member
    Posted 1 year ago #

    Thanks srijith--that fixed it for me also.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.