WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Most recent PHP version? (7 posts)

  1. MrJPH
    Member
    Posted 3 years ago #

    Hello,

    I have been wanting to naturally update to WP's latest 3.2 version, but was unclear of which exact version my web host's server was running... doing 'test.php' of my domain name, it showed I was running PHP v5.2.17.

    WP says I need to be running at least PHP v5.2.4. So, I contact my Host and ask them if it is correct that I am only running version 5.2.17, and they confirm. I explain that I run WP on my site, and that the latest WP upgrade requires version 5.2.4, when will they update the PHP on the server, especially seeing that the latest PHP is v5.3.6, and they replied they didn't have an exact date as to when updated maintenance would be performed.

    However, they went on to explain that my 5.2.17 version is actually a much later version than 5.2.4. Huh?! What?! But, check of PHP's own site, it appears to be correct! What the - ?!

    According to it, 5.2.4 actually was released clear back in August of 2007! Whilst my v5.2.17 was released in January of this year. Well now, that ain't confusing!

    I just want to check with you all that this is, odd, but correct - that my PHP v5.2.17 is actually greater/later, and therefore compatible to run the latest v3.2 of WP requiring a PHP version of 5.2.4 or greater?

    Scratching my head,
    JPH

    ***UPDATE***

    Helps, if I actually read further down the forum's posts, then I would have found the two posts in a row that address this very thing. My bad. Okay, I now know that 5.2.17 is somehow greater/later than 5.2.4! :-)

  2. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    Just to explain why it's a later version, PHP versions(and linux versions in general) can often end up with more than 10 point releases for each branch.

    For example, in PHP the "5.2" and "5.3" parts are the "major releases", the .4 is just a bugfix release.

    So it's really, PHP 5.2 branch, point release Four thats required, and you're running PHP 5.2 Branch, point release Seventeen.

    If the version was 5.2.1.7 (extra dot) then you'd indeed be running a lower version than required, as it's be point release One.. but luckely, PHP doesnt use that naming scheme :)

  3. MrJPH
    Member
    Posted 3 years ago #

    Hi, Dion -

    Yeah, I guess I am just unfamiliar with version vernacular :-) I was reading 5.2.4 as if it was 5.2.4(0), wherein it would be greater than 5.2.17... as opposed to how it is to be read as 5.2.(0)4, where it would naturally be the lesser than 5.2.17 ... at least how I am concluding it :-)

    Any, or either, way - I am just glad that I am more updated than I thought I wasn't, and that I am able to have WP's latest version... that's all that matters to me! :-)

    Thanks again for taking the time to explain it to me, as well as others who might be as uneducated on such matters as myself, Dion.

    All the best to you,
    JPH

  4. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    Thanks again for taking the time to explain it to me, as well as others who might be as uneducated on such matters as myself, Dion.

    Although you had worked it out, I thought it was worth explaining since I've seen quite a few people ask about it :) I just hope they come accross this thead & reply before asking

  5. alanhbliss
    Member
    Posted 2 years ago #

    Hi, before I get my host to update our server for the required php, does anyone know if there are any imminent plans for a further update to the version we need?

    I'm only asking because there's a charge so I don't want to do it now and again in a few months?

    thanks

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    WordPress 3.3 is likely to be released shortly but the PHP & MySQL requirements will be be the same as for 3.2.

  7. alanhbliss
    Member
    Posted 2 years ago #

    greath thanks for your help

Topic Closed

This topic has been closed to new replies.

About this Topic