WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
More Than One OG URL Specified (3 posts)

  1. Jamieoz88
    Member
    Posted 1 year ago #

    I have used this plugin for a while now with no problems. However i think my new premium theme is interfering with the plugin. When i try to use publish to my Timeline with OpenGraph (which I've been doing for months no problem) or use the Facebook Debugger for my site i get the following error:

    Object at URL 'http://distant-horizons.net/portfolio/' of type 'website' is invalid because it specifies multiple 'og:url' values: http://distant-horizons.net/portfolio/, http://distant-horizons.net/portfolio.

    I have viewed the source code for my site and have identified two OG Meta tag groups, one starting line 7 and one starting line 133. The only plugin i have active is Facebook and when i remove the plugin the two groups of meta tags are still there but i don't get any errors on the debugger... which is confusing me. Any ideas on how to solve this?
    I've tried removing the first group from the PHP file only to get more errors, and the second group i cannot find. I have also tried getting support from the theme creator but their support is quite bad.

    Hope someone can help! and thanks for your time.

    http://wordpress.org/extend/plugins/facebook/

  2. Niall Kennedy
    Member
    Plugin Author

    Posted 1 year ago #

    I do not see Open Graph protocol markup generated by the Facebook plugin for WordPress on your portfolio page. Did you disable the plugin?

    You are running FullScene version 1.3.2. Looks like version 1.3.3 came out in January but might not necessarily help.

    Wordbooker is also outputting Open Graph protocol markup. It looks like there might be a Wordbooker setting to disable Open Graph protocol output. You shouldn't need both Wordbooker and the Facebook plugin for WordPress unless there is a specific feature in Wordbooker you prefer. Wordbooker outputs incorrect Open Graph protocol markup. Wordbooker does not include an og:url, which is why you do not see the duplicate og:url error.

  3. Jamieoz88
    Member
    Posted 1 year ago #

    thanks for your reply Niall, I forgot to update this post saying i swapped out plugins as i managed to get Wordbooker working instead. So at the time it was just the Facebook plugin. I'll give the Facebook plugin a try with the latest Fullscene version. I am guessing it would be something to do with the themes built in options (although i turned them off, maybe it just disabled them being visible?) so i'll try on the slim chance that a theme update solves this.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic