WordPress.org

Ready to get started?Download WordPress

Forums

more problems uploading images (permissions are alright) (8 posts)

  1. storfisk
    Member
    Posted 7 years ago #

    Hi,

    Me too I have problems to upload images to my blog.

    I have been browsing the forums and I know it has been longly explained. But no matter how much I change the permissions for the wp-content and the uploads folder (777 or 775 etc...) , I still cannot upload images. It says
    "Unable to create (foldername)...., is (foldername)... writable?"
    . And it is!!! It is accesible with my ftp program but I canĀ“t upload through the WP.

    What could I do?
    Is there another way to upload images directly through ftp?

    thankyou

  2. gavinholt
    Member
    Posted 7 years ago #

    what are you using for hosting? I know when I use my godaddy VPS i get similar errors with mambo (site is http://www.ptcbjj.com. This is due to the php settings being in a safe mode or something that prevents the php files from writing files. I still have not found a workaround and I need to manually ftp images up to the server.

  3. storfisk
    Member
    Posted 7 years ago #

    thank you gavinholt,

    my hosting is EUROVPS it is funny because the instalation was quite automatic and everything. I will check the PHP security settings.

    Meanwhile... how do you do to include the images in the blog? I mean: you upload them via ftp to the right folder and what do you do then so that their appear in the blog? Do you have to write some kind of html link or something?

    thanks again

  4. storfisk
    Member
    Posted 7 years ago #

    nice web by the way!

  5. gavinholt
    Member
    Posted 7 years ago #

    I'm trying to get a blog up for my wedding photography tonight and I have the same problem as you. I did a test and I'll link to images from another site for now. I'll let know once I figure out my server.

  6. gavinholt
    Member
    Posted 7 years ago #

    DID IT!

    1. turn off php safemode. Godaddy link:
    http://help.godaddy.com/article.php?article_id=148&topic_id=90&&
    make sure to reboot the server

    2. Make sure you have the directory set to wp-content/uploads in your options. then create the folder. then set the permissions to 777

    This got it working for me. good luck!

  7. storfisk
    Member
    Posted 7 years ago #

    thankyou gavinholt! I will try it!

  8. feelfull
    Member
    Posted 7 years ago #

    Hi,
    I m new to wp...

    I have a error all the times i upload an image:
    Unable to create directory
    D:\Inetpub\webs\jesuismonreveorg\Blog/wp-content/uploads/2006/11. Is
    its parent directory writable by the server?

    This is what i tried to do at the moment:
    _Set the permission of wp-content to "777"
    _Created the folders "uploads", "2006", "11" and chmod 777, then i get
    this error:

    "The uploaded file could not be moved to."

    _Using the plugin "old-style-upload", i also get an error:

    Warning: copy(D:\\Inetpub\\webs\\jesuismonreveorg\\Blog/wp-content/uploads/2006/03.jpg):
    failed to open stream: Permission denied in
    D:\Inetpub\webs\jesuismonreveorg\Blog\wp-content\plugins\filosofo-old-style-upload.php
    on line 217
    Couldn't upload your file to
    D:\\Inetpub\\webs\\jesuismonreveorg\\Blog/wp-content/uploads/2006/03.jpg.

    I am desperate, what should i do?
    Marco

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags