WordPress.org

Ready to get started?Download WordPress

Forums

More Fields
More Fields (2.1) incompatible with WP 3.3 (33 posts)

  1. Albo75
    Member
    Posted 2 years ago #

    Just updated and discovered all sorts of interface display problems with the More Fields plugin. Anyone else having the same issues?

    http://wordpress.org/extend/plugins/more-fields/

  2. Martin
    Member
    Posted 2 years ago #

    just found the same thing, the WYSIWYG text field is now a tiny box with no tool bar.

  3. lem45
    Member
    Posted 2 years ago #

    my WYSIWYG field is still OK, but I can't access the data in my template. it gives me an empty array.

  4. lem45
    Member
    Posted 2 years ago #

    i just installed this one, it works all right and is even better than MORE FIELDS

    http://wordpress.org/extend/plugins/advanced-custom-fields/

  5. Merlin Mason
    Member
    Posted 2 years ago #

    I'm getting the same problems with 3.3 and more fields, I think it's to do with the new way media is uploaded. Anybody know if there's an update in the works or whether I should tryout this advanced custom fields?

  6. Catiebugx3
    Member
    Posted 2 years ago #

    I'm not having that problem. Are you sure you don't have other plugins that conflict with it?

  7. Albo75
    Member
    Posted 2 years ago #

    If I disable More Fields the problem immediately goes away so I'm pretty sure it's the issue.

  8. Catiebugx3
    Member
    Posted 2 years ago #

    Yeah, I just noticed I can't move any of the things around or anything. I'm trying to use Advanced Custom Fields but I'm completely lost on how you make it display. I love how simple More Fields is because you can put in what should be displayed before and after IF there is a value for the field, if there isn't one, nothing will show up and there won't be some odd space.

  9. lem45
    Member
    Posted 2 years ago #

    After using advanced custom fields (http://wordpress.org/extend/plugins/advanced-custom-fields/) I can strongly recommend that plugin! It is much easier to use than more fields, and it even has a decent documentation: http://plugins.elliotcondon.com/advanced-custom-fields/documentation/

  10. Ray Gulick
    Member
    Posted 2 years ago #

    I've noticed 2 problems with More Fields in one of my installations:

    1. wysyiwyg boxes in More Fields metaboxes are tiny with no toolbars

    2. all metaboxes on the edit page or edit post screen are "frozen": can't open them if they're closed, can't close them if they're open, can't drag them to another location.

    Both of these problems were noted by others above. When More Fields is deactivated, the metaboxes are "unfrozen." Of course, the More Fields metaboxes are then gone, so the wysiwyg problem in them is gone also.

    What's confusing is that I have other sites using WP 3.3 and MF 2.1, and not experiencing the same problems. So it's possible there is a conflict with another plugin.

  11. Ray Gulick
    Member
    Posted 2 years ago #

    I think I found out how to fix it. For me at least, the problem seems to occur if the standard "Custom Fields" metabox is displaying on the add/edit screens. I added the following code to my functions file to remove the custom fields metabox for both posts and pages, and the problem went away:

    // REMOVE META BOXES FROM DEFAULT POSTS SCREEN
     function remove_default_post_screen_metaboxes() {
    remove_meta_box( 'postcustom','post','normal' );
    }
    add_action('admin_menu','remove_default_post_screen_metaboxes');
    
    // REMOVE META BOXES FROM DEFAULT PAGES SCREEN
    function remove_default_page_screen_metaboxes() {
    global $post_type;
    remove_meta_box( 'postcustom','page','normal' );
    }
    add_action('admin_menu','remove_default_page_screen_metaboxes');
  12. Ray Gulick
    Member
    Posted 2 years ago #

    Spoke too soon; the problem returned. Not sure why it went away temporarily; can't figure out how to duplicate that.

  13. tydende
    Member
    Posted 2 years ago #

    I've tried a number of custom fields plugins since upgrading to 3.3 and am finding that none of them display the WYSIWYG editor anymore (which makes them useless for me).

    Has anyone found a solution to this, or has anyone from wordpress commented on this issue?

    I have tried
    More Fields
    Advance Custom Fields
    Custom Field Suite

  14. Ray Gulick
    Member
    Posted 2 years ago #

    While it has a couple of minor bugs, I have had good results using Advanced Custom Fields. The wysiwyg fields work fine for me. The really great feature I love is the ability to determine which post types and which page templates a particular custom fields metabox displays on. Also, the repeater field (costs $25; worth every penny) allows you to create repeatable (via "add another" button) custom field sets.

    For more info on WP3.3 known issues, see this post:
    http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list

  15. tydende
    Member
    Posted 2 years ago #

    Thanks Ray.

    But, I just installed and checked Advance Custom Fields again, and I am not getting the WYSIWYG editor at all. I specifically need to use the HTML editor.

    All I get in WP 3.3 is the text box with the Upload icon above the box. None of the WYSIWYG icons are visible.

    Is this not the case for you?

  16. Ray Gulick
    Member
    Posted 2 years ago #

    Not the case for me: wysiwyg editor fields in ACF showing up and doing the job.

    Wild guess: this might be a jquery version issue? I'm loading jquery 1.6.2 from google cdn; not using 1.7.1 packaged with WP3.3.

    You might look carefully at the master list for more clues.

  17. Ray Gulick
    Member
    Posted 2 years ago #

    If you want to see if jquery version is the issue, paste this in your functions.php file:

    //get jquery from google
        function jquery_init() {
            if ( !is_admin() ) {
            wp_deregister_script( 'jquery' );
            wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js', false, '1.6.2');
            wp_enqueue_script( 'jquery' );
                }
            }
    add_action( 'after_setup_theme', 'jquery_init' );

    Actually, I just noticed this script does not load jquery from google if in admin area. Might not be a solution. You could leave out the if statement and the first closing bracket.

  18. tydende
    Member
    Posted 2 years ago #

    interesting. maybe that's it.
    how are you loading the older version of jquery, or I should ask how are you preventing the packaged version from loading?

  19. tydende
    Member
    Posted 2 years ago #

    ha. got it. we were writing at the same time

  20. tydende
    Member
    Posted 2 years ago #

    That doesn't change it for me. Still no WYSIWYG editor.

    I might try deactivating all plugins and reverting to default theme, but there seem to be a lot of people having the same issue and I haven't had any problems in any other versions of wordpress. Interesting that you're still getting it though...

  21. Ray Gulick
    Member
    Posted 2 years ago #

    Turning off other plugins is a good place to start.

  22. tydende
    Member
    Posted 2 years ago #

    It is, but still no change. Thought it could be conflicting jquery.

  23. tydende
    Member
    Posted 2 years ago #

  24. Ray Gulick
    Member
    Posted 2 years ago #

    The question still hanging for me is, why does TinyMCE work in some circumstances with these plugins, but not others? Thanks for following up on this.

  25. tydende
    Member
    Posted 2 years ago #

    when i rename the file wp-includes/js/tinymce/langs/wp-langs-en.js to en.js, the wysiwyg editor works again

  26. tydende
    Member
    Posted 2 years ago #

    sorry. that did not fix it permanently. screw it. back to wp 3.2.1

  27. xtra
    Member
    Posted 2 years ago #

    Will try http://wordpress.org/extend/plugins/advanced-custom-fields/ as it explains well (documented) on how to display your data on a page which I was a bit stuck with More Fields plugin.

  28. Sam_a
    Member
    Posted 2 years ago #

    For those seeing TinyMCE/WYSIWG failures: try opening your browser's console and look for javascript errors there.

    @babypress, More Fields uses WordPress's own post metadata, so you use the get_post_meta function with the key you set when creating the field.

    Advanced Custom Fields has worked fine for me in 3.3.

  29. Bad Feather
    Member
    Posted 2 years ago #

    Hey @henrikmelin, @kalstrom,

    I love More Fields and use it on many projects. It's easily my favorite custom fields management plugin. Thank you for making it and the rest of the More plugins.

    Any chance you guys are working on an update to the More Plugins for WordPress 3.3 and beyond? I'm curious (as I'm sure the other people on this thread are) as to whether I need to jump ship and find a new solution, or whether you're still maintaining these plugins and I just need to patiently wait.

    Thanks again

  30. cadencehart
    Member
    Posted 2 years ago #

    I am using the More Fields plugin too in most of my sites. I have upgraded to WordPress 3.1.1 and I do not seem to have the issues discussed on this thread. Everything works fine on my sites...

    Except for one site wherein I cannot get the get_post_meta($post->ID, $key, true); function to work in functions.php with More fields. More info about this issue: http://wordpress.org/support/topic/more-fields-plugin-get_post_meta-function-not-working-in-functionsphp?replies=1

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic