WordPress.org

Ready to get started?Download WordPress

Forums

"more" and other front page links go to 404 page (5 posts)

  1. alkalar
    Member
    Posted 5 years ago #

    <!--more--> on the front page is working just fine, but when you click on the link, you get a 404 page.

    The same goes for the ARCHIVES and CATEGORIES links.

    On the one "more" example I have, the link is: ...blog address.../2008/10/02/watered-down-writing/#more-12. I looked in the files and the folder 2008 doesn't exist, let alone the rest of the address.

    The only thing I can think of is that I have a couple of options that are fighting with each other over where the full article belongs. I can edit the article just fine from the admin dashboard, so it's out there somewhere.

    I'm on release 2.6.2 using the default theme.

    I've gotten rid of the "more" link, but the side bar links are still there. Page is:

    Any ideas of where to look?

  2. iridiax
    Member
    Posted 5 years ago #

    You appear to be having permalinks problems.

    See: Using "Pretty" permalinks

  3. alkalar
    Member
    Posted 5 years ago #

    Thanks iridiax!

    Hoo boy! I'm using a host for the site, so I have no access to the kernel.

    Had no trouble creating an .htaccess file in the root folder for WordPress. (I hope I did it right -- I didn't use a Directory wrapper, just a single line Options Indexes FollowSymLinks But I'm not sure how to do the File Info directives since the instructions at Allow Override says it's only allowed in a Directory Context (whatever that is). Can you give me a leg up on this (I'm far from an Apache expert)?

    After I accomplish all this, what do I have to do in WordPress to repair the problems that exist? Do some sort of "refresh" operation?

    Sorry to be a pain. None of the links on the home page are working, they all seem to have this disease. Very frustrating.

  4. iridiax
    Member
    Posted 5 years ago #

    But I'm not sure how to do the File Info directives since the instructions at Allow Override says it's only allowed in a Directory Context (whatever that is). Can you give me a leg up on this (I'm far from an Apache expert)?

    Ask your web host if Allow Override is enabled.

    To reset/update your permalinks, click Save Changes on the permalinks settings page even if you haven't changed anything.

  5. alkalar
    Member
    Posted 5 years ago #

    Thanks a million, iridiax! The links all work.

    Didn't have to ask the host (they don't do a good job of replying anyway). But I did have to open up .htaccess write permission all the way (I feel naked and exposed). No other combination would work.

    Does WordPress need access to .htaccess very often? If not, I'll lock it down again. If so, I'll just have to live dangerously.

Topic Closed

This topic has been closed to new replies.

About this Topic