WordPress.org

Ready to get started?Download WordPress

Forums

more... (6 posts)

  1. Cayla
    Member
    Posted 9 years ago #

    Okay, I'm having a bit of trouble with the (more..) function. I typed in < ! - - m o r e - - > (sans spaces), and it did cut the text, but the link for the rest of the entry is not displaying. I viewed the source, and the link to the post is there, but there is no text between the a and /a code. I checked my template functions, and everything seemed okay there, so what's happening?

  2. kvillines
    Member
    Posted 9 years ago #

    The more tag splits the Post, so you have to have valid XHTML before the more tag and after the more tag. That way both sections can actually live independent of each other.

  3. serendipity
    Member
    Posted 9 years ago #

    the_content() generates the link all on its own. Which version are you running? Could we have a link to a post that exhibits the problem and the code in your loop?

  4. James
    Happiness Engineer
    Posted 9 years ago #

    You typed it in. Why not just enter it by hitting the "more" button (located in the quicktags section when you're writing a post)?

  5. Cayla
    Member
    Posted 9 years ago #

    I installed Scriptygoddess's plug-in for show/hide more, and it works now. Not sure what the problem is with the original code.

  6. eragle
    Member
    Posted 9 years ago #

    You're not limited to a text link either. I use a linked image instead of the text and it looks pretty good.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.