WordPress.org

Ready to get started?Download WordPress

Forums

Moody Plugin (12 posts)

  1. dino
    Member
    Posted 9 years ago #

    A bit new to WP so bear with me if I'm asking a stupid question. I've been trying to insatll the moody plugin that I downloaded from the following url: http://www.gudlyf.com/media/moody.phps I've followed the instructions as best I could but when I activate the plugin and try to use it I get the following error:
    Warning: Cannot modify header information - headers already sent by (output started at /home/dinoblog/public_html/wp-content/plugins/moody.php:35) in /home/dinoblog/public_html/wp-admin/post.php on line 146
    Is there something I'm doing wrong that is obvious to anyone?

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Hi Dino :)
    That's the white space error.
    Download the moody.php, and check that there is no whitespace between the <?php and ?>
    There must be nothing before the first < and nothing after the last > - not even a carriage return.
    Also, < ?php will cause an error, <?php will not
    :)

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Sorry ... that's badly phrased.
    Here's a better answer:
    Reason and Solution :
    It is usually because there are spaces, newlines, or other garbage
    before an opening '< ?php' tag or after a closing '?>' tag, typically in
    wp-config.php. This could be true about some other file too, so please check the file that gave you the error too (mentioned in the error message).

  4. dino
    Member
    Posted 9 years ago #

    Cheers Podz....that sorted it, there were two carriage returns at the end of the plugin code in the php file. Got it working but don't like the way it looks now so gonna deactivate it again! :)

  5. catsudon
    Member
    Posted 9 years ago #

    i'm a little confused. i'm trying to get this plugin to work as well and i have activated it from the admin control panel, uploaded all the images, and my test blog actually spits out the blank smiley on all posts now but i am clueless as to the custom field. what exactly is the custom field code and where do i put it? is it supposed to be a dropdown list of the filenames that i will choose from? i hope someone can help!

  6. welsper
    Member
    Posted 9 years ago #

    In Advanced Editing mode, the custom field shows up under the post field. There you can enter the custom field in.

  7. catsudon
    Member
    Posted 9 years ago #

    thanks for the reply welsper, but forgive my ignorance. i am in advanced editing mode and i'm not exactly sure where i'm looking at. can you give me an example of the text that i am supposed to be seeing and what exactly the custom field should be? i appreciate all the help you can give !

  8. catsudon
    Member
    Posted 9 years ago #

    woops, found it! thanks again, welsper.

  9. Jinsan
    Member
    Posted 9 years ago #

    hi, I've installed the plugin - well no, I've uploaded moody.php to wp-content\plugins and then \moods for the images but don't see it in the admin plugins area.

    Can anyone help?

  10. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Jinsan - have you kept in the stuff at the top of the .phps file that tells the name / author etc ?

    Was it correctly saved as a .php file, and also uploaded as an ASCII file ?

  11. Jinsan
    Member
    Posted 9 years ago #

    well i went to the plugin repository through the dashboard, and clicked on the alternative link with the zip ending which game me the moods.

    Then I realised no php file so went back and right clicked the php file and saved it. Uploaded it, and when I checked the comments above to edit it, I found that there was an insane amount of HTML. So I deleted that file and downloaded the one above - well copy and pasted it into the php file.

    I made sure there was no white space. Then edited the comments file but got this error when I clicked on the plugins dir:

    Parse error: parse error, unexpected T_STRING, expecting ')' in blahblah/wp-includes/comment-functions.php on line 216

    OK I think I edited the wrong file, actually I did. My eyes are going. I;ll get back to this if I dont' get it working

    Well it says above:
    I also recommend editing the comment_author_link() and comment_author_url_link() functions in the wp-includes/template-functions-comment.php file to read:

    Now I couldn't find the template-functions-comment.php file, but I did find functions-comments.php and that didn't work as it gave me the above error.

    So what next? Using 19/01/05 nightly build

    EDIT #456151

    I turned off the REMOVE HEADER INFO (sorry about caps) within ZA firewall. Now, this allowed me to enable the plugin (this maybe why I;m getting the referrer errors) and now the top my screens is filled with these errors.

    < ?php /* Plugin Name: NoFollow Plugin URI: http://www.gudlyf.com/archives/2005/01/19/wordpress-plugin-nofollow/ Description: Adds the "nofollow" relative attribute to links left in comments (See http://www.google.com/googleblog/2005/01/preventing-comment-spam.html) Version: 1.0 Author: Keith McDuffee Author URI: http://www.gudlyf.com */ function nofollow($text) { $text = preg_replace('/
    Warning: Cannot modify header information - headers already sent by (output started at /wp-content/plugins/moody.php:11) in /wp-admin/admin.php on line 7

    Warning: Cannot modify header information - headers already sent by (output started at /home/jinsan/public_html/wp/wp-content/plugins/moody.php:11) in /wp-admin/admin.php on line 8

    Warning: Cannot modify header information - headers already sent by (output started at /wp-content/plugins/moody.php:11) in /wp-admin/admin.php on line 9

    Warning: Cannot modify header information - headers already sent by (output started at wp-content/plugins/moody.php:11) in /wp-admin/admin.php on line 10

    I removed a little of the path. Anyway, It's apparent that I need to do something to get 1_ the referrers working and 2) any plugin in to work since I can't use any.

    If I disable it, and enable the plugin the above arises. Solution?

    Thanks again

    Edit#3269413348

    So, I looked again, I'm very....tired....I installed the No Follow thing. It seems like a useful plugin.

    Now I'll try to install the mood.php. Thing is all I did was remove the s from phps at the top link and I just assumed the first code was the right code. I guess I should remove that plugin seeing as I can't edit that second file that no longer exists

    Edit: #99988978948664592175

    Ok, so it's installed but where and how do I add a mood? read the site page and it just says install etc. Can't find any button or anything. Should this work with 1.5 or am I doing this wrong?

  12. Jinsan
    Member
    Posted 9 years ago #

    Add Custom field “mood� to posts to use one of the icons (posts with no mood show a default icon).

    So do I enter a custom field everytime I post? Is there a way to make the custom field permanent or a way to select the moods, or do I type each mood in myself. That's a lot of moods to remember!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.