WordPress.org

Ready to get started?Download WordPress

Forums

Problems of interaction beetwen style.css and editing via console (11 posts)

  1. Grivit
    Member
    Posted 10 months ago #

    Hi! I have some problem. I edit style of my montezuma theme directly from file style.css, but when I use console to add smth, all my style turns to default. How can I deal with it?

  2. WPyogi
    Volunteer Moderator
    Posted 10 months ago #

    First, you should not be modifying theme files - as your changes will be lost when the theme is updated - instead use Custom CSS or a child theme - http://codex.wordpress.org/Child_Themes

    So I'd suggest you change how you are making those changes.

    But then I'm also not even sure what you mean by:

    when I use console to add smth, all my style turns to default. How can I deal with it?

    Can you give an example and a link to it?

  3. Grivit
    Member
    Posted 10 months ago #

    Thank you for the answer. I don't know how link can help you, but here it is. Now it's okey.
    I meant, we have 2 variants to edit style, frome its file (style.css), and using console. But after I make some changes in code via console(doesnt matter .css files or .php)and then click to save, all my settings - style, templates - turns to their primal look as in default montezuma theme.
    For example, I've added some text in footer.php from console, and my style became as default. Then I have to change file style.css to its copy.

  4. Andrew
    Forum Moderator
    Posted 10 months ago #

    What do you mean "console"?

  5. Grivit
    Member
    Posted 10 months ago #

    site.com/wp-admin/themes.php?page=montezuma editing from this place for me = editing from console.

  6. Andrew
    Forum Moderator
    Posted 10 months ago #

    Have you tried adding your CSS through a Child Theme?

  7. Grivit
    Member
    Posted 10 months ago #

    Not yet. I should read about this, at fist)
    But looks good, I'll try and answer then.

  8. Grivit
    Member
    Posted 10 months ago #

    Well, child theme didn't help.. Created folder "montezuma-child", added style.css with this code

    [ Moderator note: please wrap code in backticks or use the code button. Don't use blockquote it doesn't work. ]

    /*
    Theme Name: Montezuma
    Theme URI: http://wordpress.bytesforall.com/wordpress-themes/montezuma/
    Description: Montezuma is a responsive, customizable and search engine optimized HTML5 / CSS3 theme. Choose between responsive, flexible and static layouts. Edit or create new page templates online, without FTP uploads. Add custom widget areas everywhere. Colorbox slideshow for standard WP galleries, auto post thumbs, advanced excerpts, Google fonts, transparent color picker, import/export settings and more. This is the second theme from the author of the popular "Atahualpa" theme. Active community at forum.bytesforall.com. 
    
    Version: 1.1.9
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Tags: light, white, gray, blue, one-column, two-columns, three-columns, left-sidebar, right-sidebar, fixed-width, flexible-width, custom-menu, featured-images, post-formats, sticky-post, theme-options, threaded-comments, translation-ready
    Text Domain: montezuma
    Template:    montezuma
    Author: BytesForAll
    Author URI: http://wordpress.bytesforall.com/
    */
    /* =Imports styles from the parent theme
    -------------------------------------------------------------- */
    @import url('../themes/montezuma/style.css');
    /* =Theme customization starts here
    -------------------------------------------------------------- */

    Then added all the code from style.css (btw, there is few style.css and I use the one, which located in wp-content/uploads/montezuma). Everything is okey, until I made some change in administration panel.
    :|

  9. This line will not work.

    Theme Name: Montezuma

    It can't be the same name as the parent. Try this line instead.

    Theme Name: Montezuma Child Theme

    Activate that one and see what happens.

  10. Also next time please consider using the correct dedicated sub-forum.

    http://wordpress.org/support/theme/montezuma

    Just putting [Montezuma] in the subject line (deleted) doesn't do anything. By using the correct sub-forum you increase the chances of your problem being seen by the right people.

  11. Grivit
    Member
    Posted 10 months ago #

    Doesn't help. I'm frustrated. But thank you!
    Actually, it's not so bad, I just should always have copy of this damned style.css :)

Reply

You must log in to post.

About this Topic