WordPress.org

Ready to get started?Download WordPress

Forums

Multisite Language Switcher
[resolved] Modifying link (3 posts)

  1. Photoed
    Member
    Posted 1 year ago #

    Hi,

    I have successfully installed MSLS on photoed.co.uk and it has been working perfectly for the last 3-4 weeks.

    I have made some amendments to the site today, including swapping the position of the header/menu and placing the flag icon into the header.

    When testing the new position of the header, it seems that one of the links generated by the plugin is now incorrect.

    The home page at photoed.co.uk/fr now links back to photoed.co.uk/photoed instead of just photoed.co.uk. Strangely, the link from photoed.co.uk still correctly links to photoed.co.uk/fr.

    This is the only link that has changed for an unknown reason, all the others seem to still work correctly.

    Have you any idea why a link may change of its own accord and how I can correct it again?

    I have already tried updating the link from the 'edit page' screen but it hasn't worked.

    Many thanks for any assistance you can provide.

    Edward

    http://wordpress.org/extend/plugins/multisite-language-switcher/

  2. realloc
    Member
    Plugin Author

    Posted 1 year ago #

    Edward,

    it seems that you have added the string 'photoed' in the configuration of the primary blog. If you just visit the permalink setup in the settings section of your blog (without clicking anything) it will reload the rules and in most cases that's it.

    Cheers,
    Dennis.

  3. Photoed
    Member
    Posted 1 year ago #

    Hi,

    Thanks for the steer in the right direction.

    It turns out I had edited the wp_options table entry for site url when I had some difficulties migrating to multisite.

    Turns out I just needed to change the entry back to photoed.co.uk only.

    Many thanks.

    Edward

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.