WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Moderating Comments: Comments Won't Approve (14 posts)

  1. vietknight
    Member
    Posted 5 years ago #

    In the past, this function has worked for me, but recently I am having some problems moderating user comments in the Admin Dashboard.

    I currently have 3 posts that show up in my comments that are "awaiting moderation".

    WP provides multiple ways to approve these comments, and I have tried all combinations to approve them, however with no success.

    For example, if I try to moderate them by clicking the Approve button on the right-hand side, under the Actions, I see the non-moderated comments fade from yellow to white, and the Approve text changes to "Unapprove"

    If I try check-boxing the three posts, and pressing on the button Approve, it takes me to a blank page with the address:

    "mysite.com"/blog/wp-admin/edit-comments.php?comment_status=moderated

    which in place for mysite.com is my domain of course.

    Anyone got any tips on how to fix this?

    Just as a test, I tried to see if "mark as spam" worked, and which it did, not sure if that info will help though.

  2. moshu
    Member
    Posted 5 years ago #

    For example, if I try to moderate them by clicking the Approve button on the right-hand side, under the Actions, I see the non-moderated comments fade from yellow to white, and the Approve text changes to "Unapprove"

    That should mean the comment is approved, but if you change your mind you can put it again in the moderation queue by clicking on "unapprove".

  3. vietknight
    Member
    Posted 5 years ago #

    Oh, sorry I forgot to mention, when I refresh the page, it comes up as "Unapproved".

  4. vietknight
    Member
    Posted 5 years ago #

    I just checked my error log and found this:

    [Tue Sep 09 16:29:41 2008] [error] [client 74.86.240.236] ALERT - function within blacklist called: ignore_user_abort() (attacker '74.86.240.236', file '/home/vievie/public_html/blog/wp-cron.php', line 12)
    [Tue Sep 09 16:29:41 2008] [error] [client 142.58.24.204] ALERT - script tried to increase memory_limit to 33554432 bytes which is above the allowed value (attacker '142.58.24.204', file '/home/vievie/public_html/blog/wp-settings.php', line 16), referer: http://vietknight.x10hosting.com/blog/wp-admin/edit-comments.php
    [Tue Sep 09 16:29:39 2008] [error] [client 74.86.240.236] ALERT - function within blacklist called: ignore_user_abort() (attacker '74.86.240.236', file '/home/vievie/public_html/blog/wp-cron.php', line 12)
    [Tue Sep 09 16:29:39 2008] [error] [client 142.58.24.204] ALERT - function within blacklist called: mail() (attacker '142.58.24.204', file '/home/vievie/public_html/blog/wp-includes/class-phpmailer.php', line 437), referer: http://vietknight.x10hosting.com/blog/wp-admin/edit-comments.php?comment_status=moderated
    [Tue Sep 09 16:29:39 2008] [error] [client 142.58.24.204] ALERT - script tried to increase memory_limit to 33554432 bytes which is above the allowed value (attacker '142.58.24.204', file '/home/vievie/public_html/blog/wp-settings.php', line 16), referer: http://vietknight.x10hosting.com/blog/wp-admin/edit-comments.php?comment_status=moderated

    It seems there's a script trying to increase the memory limit which is beyond what my host allows.

  5. vietknight
    Member
    Posted 5 years ago #

    This has been fixed. It was due to some server restrictions on certain functions as well as memory_limit issues.

  6. betoranaldi
    Member
    Posted 5 years ago #

    I have this same problem. WordPress was working fine one day and then I updated it to the latest version and now comments won't approve.

    Does anyone know exactly what settings need to change?

  7. betoranaldi
    Member
    Posted 5 years ago #

    For anyone else having this problem, 2.6.3 seemed to fix this issue.

  8. aznewt
    Member
    Posted 5 years ago #

    I recently upgraded to 2.6.3 and now I am experiencing the same issue. When I approve a comment, it is removed from the list, but it will not show on the post. when I go back to the comments list, the the same two are back again as unapproved.

  9. phre4k187
    Member
    Posted 5 years ago #

    I am using WordPress 2.7 and have the same issue. Where did you find the error log?

  10. Alvyn
    Member
    Posted 5 years ago #

    I am using wp 2.7 as well. My problem is I did not even see "Approve" appear in the drop down menu in the bulk action section. Anyone can give me some tips how to solve this?

    Thanks.

  11. PaulaDaunt
    Member
    Posted 5 years ago #

    I'm using WordPress version: 2.8
    Same problem, can't approve my comments

  12. PaulaDaunt
    Member
    Posted 5 years ago #

    Guys, I found fix, but its not a permanent one.
    Edit the comment in question, then select "Approved" from the status menu.. and its approved> Obviously its not a final solution, but its a temporary one!

  13. rondeau
    Member
    Posted 5 years ago #

    When I checked the ip address of the message I wanted to approve at http://www.mxtoolbox.com/blacklists.aspx it was blacklisted. Night have something to do with it.

  14. hilts50
    Member
    Posted 4 years ago #

    I'm using WordPress 2.8.4 and still can't approve comments unless I edit the comment, mark it as approved, and save the comment. The Ajax approval doesn't seem to work. When I click approve it changes as if it were approved, but as soon as I refresh, or go to another admin page the comment is asking to be approved again. Has anyone found a real fix for this?

    thanks,

    Bill

Topic Closed

This topic has been closed to new replies.

About this Topic