WordPress.org

Ready to get started?Download WordPress

Forums

mod_rewrite not being loaded in Apache under Windows (7 posts)

  1. djuritz
    Member
    Posted 8 years ago #

    mod_rewrite is not being loaded, because is doesn't appear in phpinfo()
    Why it is not being loaded?

    Is there any problem with mod_rewrite under Apache for Windows?

    My httpd.conf is
    LoadModule rewrite_module modules/mod_rewrite.so
    AddModule mod_rewrite.c

    what's wrong with it?
    There is a file maned mod_rewrite.so in modules folder

    Thanks in advance.

  2. Ethilien
    Member
    Posted 8 years ago #

    Try editing the .htaccess file and putting something in that will definitely cause an error, and see if apache throws one. If it doesn't, then you need to edit your apache.conf, because apache is probably using a different name for the .htaccess file.

    Change this line to:
    AccessFileName .htaccess

  3. djuritz
    Member
    Posted 8 years ago #

    Ethilien: it works!!
    I've changed override from none to all

    Thanks a lot!

  4. colormeow
    Member
    Posted 7 years ago #

    djuritz,

    how u get it work? mine one still don work. i had php4/apache2/mysql4 installed in my windows xp, and i had also installed wordpress2. everything was working fine except the permalinks :(

    i had enabled LoadModule rewrite_module modules/mod_rewrite.so in httpd.conf and .htaccess also created in my wordpress. anyhow it doesnt work for me... can u or anyone ot there can halp me :(

    thank you.

  5. moshu
    Member
    Posted 7 years ago #

    See the Notes at the bottom of this page:
    http://www.tamba2.org.uk/wordpress/xampp/
    (maybe it helps)

  6. colormeow
    Member
    Posted 7 years ago #

    hi moshu,

    i had don tat, in my previous msg, i had said i had enabled it :P

  7. chunkit
    Member
    Posted 7 years ago #

    hi djuritz,

    yo solution very helpful to me. Thank a lot :)

Topic Closed

This topic has been closed to new replies.

About this Topic