WordPress.org

Ready to get started?Download WordPress

Forums

mod_rewrite and 500 error /dreamhost (5 posts)

  1. Renee
    Member
    Posted 10 years ago #

    I am trying to update my htaccess to do the following two things:
    1. change my permalink structure. I have copy-pasted the mod_rewrite rules to the file, and have gotten the 500 error. I have tried enclosing the RewriteEngine commands in IfModule tags, but it did not help.
    2. redirect my old MT files using .htaccess. I keep getting the 500 server error.
    I am now changing my .htaccess to its previous state (no redirect or mod_rewrite rules) because right now my site is not accessible. I understand that the 500 error might somehow be connected to my server -Dreamhost.com.
    Ideas and help would be appreciated!

  2. Renee
    Member
    Posted 10 years ago #

    I've figured this out. On the Dreamhost server, the default PHP is CGI, not Apache. Once I switched to Apache, the mod_rewrite worked.
    If you are on Dreamhost, read this portion of the Kbase and follow the instructions:
    https://panel.dreamhost.com/kbase/index.cgi?area=2933&keyword=mod_rewrite
    :)
    Renee

  3. Ruby Sinreich
    Member
    Posted 9 years ago #

    I am using Dreamhost as well, and I made this change but it still doesn't work! I even set up custom error pages in my .htaccess file, and they work fine, so I know .htaccess is in the right place and has the right permissions, etc.
    Since disabling PHP as CGI, I don't get 500 errors all the time, but now I get a 404 error when I try to follow the WP-generated permalink. Plus it doesn't find my custom error handling document, I guess because it's not in the directory where the permalink should be.
    Any advice?

  4. Ruby Sinreich
    Member
    Posted 9 years ago #

    Anyone have ideas about why why my rewriting doesn't work? In fact adding the rewrite rules to the htaccess file make the error handing not work anymore - and causes even the base page of the site to generate a 500 error! Not that it will help , but here's where I'm working:wp.OrangePolitics.org
    I am using Dreamhost as well, but I have disabled PHP as CGI. Any other clues?

  5. Ruby Sinreich
    Member
    Posted 9 years ago #

    Omygod, I fixed it. Pasting the rewrite rules via the WordPress interface did the trick! I hope this is helpful to anyone else who has the same problem....

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.