WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] mod rewrite permalinks index.php (5 posts)

  1. yesmaybe
    Member
    Posted 3 years ago #

    I have IIS7 server with a couple of domains with wordress installed.

    The ISAPI rewrite filter is setup and works on one domain. It was working on the other domain, but the server overloaded and I had to reinstall the services.

    I have the web.config setup as below (same on both domains), but permalinks does not work properly.

    If default permalink, then http://www.forbiddencityfc.com works. If pretty permalinks, then http://www.forbiddencityfc.com does not work, but http://www.forbiddencityfc.com/index.php works. http://www.forbiddencityfc.com/contact/ loads the main page. Other links properly. If you search Google, this page is cached [http://www.forbiddencityfc.com/2011/03/weekly-update/] so permalinks where working before the server failed.

    Any idea what IIS7 settings I should look at, reboot, or check?

    [Code moderated as per the Forum Rules. Please use the pastebin]

  2. yesmaybe
    Member
    Posted 3 years ago #

    sorry, code should be as follows.

    Basically, without permalinks, the old links don't work. With pretty permalinks, all pages work except http://www.forbiddencityfc.com/ you NEED to include the index.php which obviously isn't ideal when looking at the site root.

    [Code moderated as per the Forum Rules. Please use the pastebin]

  3. yesmaybe
    Member
    Posted 3 years ago #

    Hi Songdogtech,

    yes, that is one resource I have used.

    I have since found out the problem, it seems I was set up on PHP 4.4.7 and I needed PHP 5.2.13 run as CGI script.

    At least changing that setting seemed to fix the issue.

    Thanks.

  4. qx3579
    Member
    Posted 2 years ago #

    PLEASE help!!! I have the same problem...pretty perms work great except on homepage. I have set to use php 5.2.6 run as fastcgi (have switched to cgi just to see if it would help - it didn't). Plus I was having the problem of always having to include "index.php" in site root url. I SOMEHOW fixed that problem but now I'm stuck with a homepage that says "This is somewhat embarrassing, isn’t it?" or ugly permalinks.

Topic Closed

This topic has been closed to new replies.

About this Topic