WordPress.org

Ready to get started?Download WordPress

Forums

Mod rewrite is not installed! Super Cache will not fully work! (3 posts)

  1. flobaby
    Member
    Posted 6 years ago #

    Don't know why I'm getting this warning message, Mod Rewrite is enabled. WP-Cache is working fine, just the Supercache isn't (the index page has been supercached, but the folders that get made are empty). Here's my .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{HTTP_COOKIE} !^.*comment_author_.*$
    RewriteCond %{HTTP_COOKIE} !^.*wordpressuser.*$
    RewriteCond %{HTTP_COOKIE} !^.*wp-postpass_.*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1index.html.gz [L]

    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{HTTP_COOKIE} !^.*comment_author_.*$
    RewriteCond %{HTTP_COOKIE} !^.*wordpressuser.*$
    RewriteCond %{HTTP_COOKIE} !^.*wp-postpass_.*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1index.html [L]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  2. flobaby
    Member
    Posted 6 years ago #


  3. Donncha O Caoimh
    Member
    Posted 6 years ago #

    What web server are you using? Apache? Anything unusual about your php config? Is it mod_php or fcgi? Is php safe mode enabled?

Topic Closed

This topic has been closed to new replies.

About this Topic