WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
Mobile theme off button does not work (14 posts)

  1. LD Jackson
    Member
    Posted 1 year ago #

    After the latest update of WordPress and WP Touch, the on/off button in the footer does not work. I have tried it on two different Androids and one iPhone.

    http://www.ldjackson.net

    http://wordpress.org/plugins/wptouch/

  2. LD Jackson
    Member
    Posted 1 year ago #

    I just updated to 1.9.8 and the on/off button in the footer is still not working.

  3. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Please check if another one of the active plugins is conflicting with WPtouch by briefly deactivating each one at a time and see if you find the culprit. You can also try enabling "Restricted Mode" in the WPtouch admin panel and see if that helps resolve the issue.

  4. mahlemiut
    Member
    Posted 1 year ago #

    Same here.
    Deactivation of all plugins is no option and restricted mode does not help.
    Tested under WP3.6

  5. drunkfox
    Member
    Posted 11 months ago #

    Hi.
    I have same issue...
    http://www.guidedolomiti.com/news/
    Any help please?

  6. SBMongoos
    Member
    Posted 11 months ago #

    Just set up this plugin today and having issues with this feature working. I see the button on the bottom of the mobile page but when when I switch off there is no way to switch back to the mobile view from the desktop view.

    Is the link that's added to the desktop view "Switch to our mobile site"? It simply refreshes the page and I'm still on the desktop view.

    Using WordPress 3.6.

  7. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 11 months ago #

    This issue sounds as if you have a caching plugin serving cached mobile pages that are blocking your live site. You may configure your caching plugin not to cache mobile pages nor to serve cached pages when mobile devices are detected. To do so, enter the user agents found under Advanced Options > Custom User-Agents to the "rejected user agents" areas in your caching plugin's settings. Remember to clear your plugin, browser, and device caches before retesting.

  8. SBMongoos
    Member
    Posted 11 months ago #

    I believe I followed these steps earlier and again just now but no change. Not sure what I could be missing. I do not see "rejected user agents" but I do see: The currently enabled user-agents are: AdsBot-Google, Android, BB10, BlackBerry 9350, BlackBerry 9360, BlackBerry 9370, BlackBerry 9380, BlackBerry 9780, BlackBerry 9790, BlackBerry 9800, BlackBerry 9810, BlackBerry 9850, BlackBerry 9860, BlackBerry 9900, BlackBerry 9930, BlackBerry9500, BlackBerry9520, BlackBerry9530, BlackBerry9550, CUPCAKE, Googlebot-Mobile, bada, dream, froyo, iPhone, iPod, incognito, s8000, webOS, webmate

    I am using WP Super Cache.

    Site: http://www.yourwns.com

    Not sure what I may be doing incorrectly.

  9. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 11 months ago #

    @SBMongoos, you need to set up WP Super Cache to reject mobile user agents. See the instructions above.

  10. SBMongoos
    Member
    Posted 11 months ago #

    Just found: "Mobile device support. (External plugin or theme required. See the FAQ for further details.)" Under advanced and unchecked it. However, now after clearing my S3 browser cache it loads the desktop site. If click on the link at the bottom to switch to mobile site it does but then I cannot switch back. I have the On/Off button on the mobile site but which I click on Off it simply refreshes the mobile site.

  11. drunkfox
    Member
    Posted 11 months ago #

    I continue to have the same issue, the on/off button in the footer doesn't work.
    I bought a different plugin and it work fine...
    I don't mind to spend same money, and I prefer WP Touch Mobile Plugin also, but unfortunately it doesn't work anymore on two of my websites.
    I understand that there are so many themes and sites with many plugins, but here I hadn't any help...
    Anyway, thank you for a great plugin that I'm still using in others sites.

  12. SBMongoos
    Member
    Posted 11 months ago #

    -> drunkfox - what mobile plugin are you using.

    Now I cannot get the mobile site to come up.

  13. drunkfox
    Member
    Posted 11 months ago #

    @SBMongoos - Now I'm using Obox Mobile 2.
    As I said, I prefer WP Touch but it doesn't work...

  14. arehan
    Member
    Posted 11 months ago #

    Same here I'm afraid. WPTouch seems to work OK without much setup, but the button for turning off Mobile Theme doesn't work.

    Also: shortcodes are not expanded before showing! Any workaround for this? Rather important...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.