WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
[resolved] Mobile Theme Displayed to Desktop Users (5 posts)

  1. foreverlearning
    Member
    Posted 9 months ago #

    Love the plug in for mobile but I seem to have experienced an issue at http://projectcamelot.info where the mobile theme is overriding the default theme and is being displayed to desktop users. I am running W3 Total Cache as an FYI

    Thanks for any help

    Dan

    http://wordpress.org/extend/plugins/wptouch/

  2. foreverlearning
    Member
    Posted 9 months ago #

    Ok I just emptied all W3 total cache, caches and the issue appears to have resolved itself but has also given rise to a new issue where no mobile them is now displayed to mobile devices.

  3. foreverlearning
    Member
    Posted 9 months ago #

    W3 total cache does seem to introduce inconsistent results and upon deactivation all seems to work well.

  4. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 9 months ago #

    You may configure your caching plugin not to cache mobile pages nor to serve cached pages when mobile devices are detected.

    Note: It is required to have “Browser Cache” disabled in W3 Total Cache as there is currently no option to exclude user agents from that caching method.

    1. Go to the “Page Cache” settings under the Performance tab.
    2. Copy the list of mobile user agents found in our list of “User agent list for configuring cache plugins“.
If you have added support for additional mobile devices in WPtouch, you must also include those user agents in the “Rejected User Agents” area in W3 Total Cache.
    3. Scroll down to the “Rejected User Agents” field and paste the list of WPtouch default user agents, adding one per line. Save your changes.
    4. Go to the “Minify” settings under the Performance tab.
Scroll down to the “Rejected User Agents” field and paste the list of WPtouch default user agents, adding one per line. Save your changes.
    5. Go to the “CDN” settings under the Performance tab.
Scroll down to the “Rejected User Agents” field and paste the list of WPtouch default user agents, adding one per line.
Save your changes.
    6. Finally, go to the “General Settings” under the Performance tab and select “Empty All Caches”.
    7. Your site should now be configured correctly to work with WPtouch and W3 Total Cache.

  5. foreverlearning
    Member
    Posted 9 months ago #

    Thank you for the reply.
    I'll activate Total Cache again and follow your very helpful and clear instructions.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.