WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Browser Check
[resolved] Mobile Browser Support (16 posts)

  1. fatrod
    Member
    Posted 1 year ago #

    Great plugin, but I realised yesterday that it is also popping up on mobile browsers which is a real problem.

    Is there any intention to add support for mobile browsers?

    http://wordpress.org/extend/plugins/advanced-browser-check/

  2. manoucho
    Member
    Posted 1 year ago #

    Hi Mattias

    I had the same issue yesterday. The plugin pops up on mobile browsers (dolphin)

    It is a big issue because on the device I was testing yesterday, the pop-up window was bigger than the screen: however you could not move the window to access the HIDE button, it was moving the website behind!

    Very big issue :(

    As a short-term solution, instead of fully supporting mobile browsers, you might want to only check the browsers whose boxes are checked-in ?

    Thanks and keep up the good work Mattias!

  3. manoucho
    Member
    Posted 1 year ago #

    Support died overnight ? Hope not due to Sandy hurricane. :)

  4. Mattias
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Support did not die, away on some vacation, needed :)

    I understand your issues and will look into a solution but can't give you any timeframe atm.

  5. manoucho
    Member
    Posted 1 year ago #

    Haha. Thanks for your message. Enjoy your vacations!

  6. Mattias
    Member
    Plugin Author

    Posted 1 year ago #

    Hi @manoucho

    Now I'm back from both vacation and shit loads of work!

    For now, I have made so that no popup will be displayed on mobile or tablet devices running any version of iOS and Android. And that regarding what settings you have for the plugin.

    I might add the option to control those devices in the future.

  7. manoucho
    Member
    Posted 1 year ago #

    Wow, great, thanks for this fix!

  8. fatrod
    Member
    Posted 1 year ago #

    Hi MAttias,

    Still showing up on Dolphin and Chrome mobile for me.

    Version 2.1.1

  9. Mattias
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I have no issues in Chrome on my android mobile.

    Have you tried clearing the cache in chrome and dolphin after updating my plugin?

    Can you also provide me the settings you have on the settings page so I can test with the same settings you use.

    Thanks / M

  10. fatrod
    Member
    Posted 1 year ago #

    Hi Mattias,

    Chrome crashing on me atm, still happening in Dolphin though after clearing cache and fresh install.

    Settings are:

    Let user hide the popup: yes

    Browsers to link: Firefox, Chrome

    Browers to check:

    Do not block Safari, Opera, Firefox, Chrome.

    Block IE8 or lower

  11. Mattias
    Member
    Plugin Author

    Posted 1 year ago #

    Hi @fatrod

    I have tested my plugin on my android phone with Dolphin browser and I have no issues.

    I have tested with the exact settings you gave me above and the popup never shows. Everything looks as it should for me. For now, I'm out of ideas :(

  12. gsingh93
    Member
    Posted 1 year ago #

    Hi Mattias,

    The popup displays for me in the stock Android browser on my Galaxy Nexus running Jelly Bean (Android 4.2). Note that this isn't Google Chrome for Android.

    Can you duplicate this behavior?

  13. gsingh93
    Member
    Posted 1 year ago #

    I though it might be useful to give you the user agents of my mobile browsers.

    UA for stock browser (incorrectly giving popup):
    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.34 Safari/534.24

    UA for chrome for android (correctly not giving popup):
    Mozilla/5.0 (Linux; Android 4.2.1; Galaxy Nexus Build/JOP40D) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.166 Mobile Safari/535.19

  14. Mattias
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Thanks for the user agent strings, that helps a lot. The reason the popup shows for you in the stock browser is that the user string does not contain "Android" ad the Chrome from Android browsers user string does.

    Mu plugin is looking for just "android" in the user agent. I will look into this and see if I can find a solution or way around this.

  15. Mattias
    Member
    Plugin Author

    Posted 1 year ago #

    Hi again,

    I'm sorry to say that I have no way around this problem. From the user agent string your stock browser give, it is impossible to know that is from a Android device, or a mobile device in general.

    In the user agent string from Google Chrome, it says "android" and thanks to that I know, and the plugin, that the user is coming from a Android device.

  16. gsingh93
    Member
    Posted 1 year ago #

    One not so great solution would be to detect if the version of Chrome is extremely low (chrome is on version 24 now and the android browser is on 11) and disable the check for those browsers since it's highly unlikely someone would be using Chrome 11 unless they were on a phone.

    You could put a disclaimer saying the feature is experimental and not guaranteed to work, as this method isn't foolproof. But as a user, it's worth having the option.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.