WordPress.org

Ready to get started?Download WordPress

Forums

WP-PageNavi
[resolved] Missing ... when not using Prev/Next links (5 posts)

  1. RavanH
    Member
    Posted 3 years ago #

    When there are more pages than the maximum number to display (in my settings the default 5) and when having disabled the 'Previous page' and 'Next page' links ( « and » ) there are no intermediary three dots ( … ) displayed between the last of the normal page list and the first page jump. Also between the page jumps. This results in the following.

    For example when on the 5th page of a site with more then 20 pages:

    | First page | ... | 3 | 4 | 5 | 6 |7 | 10 | 20 | ... | Last page |

    It would be less confusing to do this instead:

    | First page | ... | 3 | 4 | 5 | 6 |7 | ... | 10 | 20 | ... | Last page |

    Where of course the three dots between the normal list and the first page jump would NOT be a link as it is would be when using … for the Previous and Next page link texts...

    Hope I explained it clear enough :)

  2. RavanH
    Member
    Posted 3 years ago #

    Some extra reasoning for NOT using the Prev/Next links: the order is illogical and highly confusing for blind people using a screen reader.

    For instance when on the front page of a site with 4 pages and this page list:
    | 1 | 2 | 3 | 4 | » |
    the order of pages linked to is:
    page 2, page 3, page 4, page 2.

    This can cause some annoying and unexpected behaviour and people dropping off because of it.

  3. scribu
    Member
    Plugin Author

    Posted 3 years ago #

    I agree that it makes no sense to put the prev/next links between page numbers:

    https://github.com/scribu/wp-pagenavi/commit/0fc6eea7d13b131d51faaaf1439f979faf9e2a1a

  4. RavanH
    Member
    Posted 3 years ago #

    So... this is in the development release? :)

  5. scribu
    Member
    Plugin Author

    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic