WordPress.org

Ready to get started?Download WordPress

Forums

WebLibrarian
Missing User Roles (16 posts)

  1. baustin
    Member
    Posted 1 year ago #

    When WebLibrarian is installed, the settings page is accessible, but the roles in the user page are not present.

    http://wordpress.org/extend/plugins/weblibrarian/
    (WP Version 3.5.1)

  2. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    I cannot reproduce this error. Are you sure you activatied the plugin?

  3. baustin
    Member
    Posted 1 year ago #

    Yes. I am using a Word Press installation on Red Hat OpenShift (I don't know if that makes a difference). Link to the git repository my installation os based on: git://github.com/openshift/wordpress-example.git.

  4. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    Can you post a screen shot illustrating the problem? If the plugin is in fact installed properly and activated, the roles should be there. I don't see how they could not be, unless you have a broken install of WordPress, in which case nothing should be working at all (and you would not have been able to install the Web Librarian in the first place).

  5. baustin
    Member
    Posted 1 year ago #

  6. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    This is totally strange. There is more wrong here -- there isn't the page icon there should be on the config page. It almost looks like you have a screwed up install somehow.

    All I can suggest is that you deactivate the plugin, delete it and install and activate it all over again. If that does not work, I am at a total loss.

  7. baustin
    Member
    Posted 1 year ago #

    I've tried that, and I've tried re-installing it both from the zip file and from WP. I wonder if there is something weird about the installation on OpenShift. I'll try posting to the OpenShift forums (and maybe even on a different site).

  8. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    Did you ever figure out what went wrong?

  9. baustin
    Member
    Posted 1 year ago #

    No. I posted to the OpenShift forums. I'll give you a link to the post…

    https://www.openshift.com/forums/openshift/wordpress-plugin-problem

  10. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    Did you ever manage to find out what happened? Noone else has reported this problem.

  11. baustin
    Member
    Posted 1 year ago #

    No. The person who posted on the link above had the problem on both an OpenShift site and on another site.

  12. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    Are you sure the other person has the *same* problem or a different one. Because of the way the capabilities and roles are set up, it is possible to get a first impression that the plugin is not working -- eg the the various admin pages appear missing.

    *No one* else has reported the problem you have had. *I* am unable to reproduce it.

    Question: what theme are you using? Do you have any other plugins installed and activated? It is possible (?) that there is a conflict with either the theme and/or another plugin. I am not sure how that would result in the error you are getting, but it might be a starting point.

  13. baustin
    Member
    Posted 1 year ago #

    what theme are you using?

    The default theme.

    Do you have any other plugins installed and activated?

    I don't think so. The only thing that I installed is this plugin. What version has this been tested with? I'm using 3.5

  14. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    It has been tested up to the current version, 3.5.1. You are not running WP on a MS-Windows server? If so, all bets are off.

  15. baustin
    Member
    Posted 1 year ago #

    You are not running WP on a MS-Windows server?

    I'm running it on Red Hat openshift, which I assume uses RHEL.

  16. Robert Heller
    Member
    Plugin Author

    Posted 1 year ago #

    I don't know what to say. It works fine on a CentOS 5 (binary compatible with RHEL 5). I do have a newer version of php (installed from te IUS repo).

    Please find out *exactly* what is running on openshift: which version of rhel, which versions of mysql and php, and *exactly* what sort of WP is installed (eg is it a multisite version?).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.