WordPress.org

Ready to get started?Download WordPress

Forums

Missing theme editor and plugin editor (12 posts)

  1. paynehd
    Member
    Posted 1 year ago #

    Hi,

    I have no idea why both theme editors are not available.

    According to the codex, WordPress contains two built-in editors that allows you to edit Theme files directly from within your browser. They are called the Theme Editor and Plugin Editor.

    On a fresh install of 3.5 and update 3.5.1, neither editors show up.

    What am I missing here?

    Thanks in advance,

  2. Ryan Yu
    Member
    Posted 1 year ago #

    Hi paynehd,

    Are you on a multisite network? If so, you need to check on the Network dashboard.

    If not, maybe one of your plugins may cause this. So check your plugins by deactivating each plugin to see if it helps.

    Let me know how it went.

  3. paynehd
    Member
    Posted 1 year ago #

    Hi Ryan,

    I'm not on multi site...

    Install is on my local windows box and the other on a hosted Linux site. Both installs are fresh...wp 3.5 with default plugins...only plugins are aksimet and hello dolly...and are not active...

    thanks

  4. Ryan Yu
    Member
    Posted 1 year ago #

    Hi paynehd,

    Have you ever installed a security plugin like "BulletProof Security"?
    If so, that might be causing the issue. Check out the .htaccess file and remove the security related lines if you have removed the plugin.

  5. paynehd
    Member
    Posted 1 year ago #

    Never have installed BulletProof...and no other..

    I just createe a brand new site within the last 5 minutes...on my hosting account and same issues...upgraded to 3.5.1...hosted on Fedora/apache/mysql/php etc..

    Switched theme from twenty12 to twenty11..didn't matter.

    The htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  6. Ryan Yu
    Member
    Posted 1 year ago #

    Hi paynehd,

    That's odd. If it's a fresh install, I guess it would be more about the server side issue.
    Have you checked the file permission? Check out the file permissions part here:
    http://codex.wordpress.org/Editing_Files

  7. paynehd
    Member
    Posted 1 year ago #

    On the host server (linux) with the fresh install, I changed file perm 777 for theme dir and all sub-dirs and it did not help.

    Then, I changed all files to 666 per the codex link, and the Appearance menu still does not have the editor button.

    On my local machine (windows xp) I'm logged in as admin with a fresh install and have the same issues.

    I'm going to look around the core and see if I can find where the editor button is enabled/displayed etc...perhaps that may shed some light....

    thanks

  8. Ryan Yu
    Member
    Posted 1 year ago #

    Hi paynehd,

    I think it is something related to the permissions (maybe at the server side?) as some of my clients' sites also don't have the editors, but they are all because of the security plugins.

    If you are having the same issue on your hosting server, you may want to ask your hosting company. They might be helpful.

  9. paynehd
    Member
    Posted 1 year ago #

    Ryan et al,

    I just figured it out...In my over zealous attempt to secure my site, I added the following "define" in my wp-config.php file...which removes the "editor" item from Appearance menu.

    /** Hardening WordPress **/
    define('DISALLOW_FILE_EDIT', true);

    thanks for your help

  10. Ryan Yu
    Member
    Posted 1 year ago #

    Good to hear the issue is resolved! And that's another good point to learn :)

  11. wick3dsono
    Member
    Posted 1 year ago #

    i have a same issue, link

    but after i open the wp-config, I didn't find the statement,

    /** Hardening WordPress **/
    define('DISALLOW_FILE_EDIT', true);

    any other suggestion?? thanks

  12. wick3dsono
    Member
    Posted 1 year ago #

    I'm multisited, network dashboard solved all. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic