WordPress.org

Ready to get started?Download WordPress

Forums

Missing roles menu in add new user; missing multisite listing in My Sites menu (15 posts)

  1. daseincog
    Member
    Posted 2 years ago #

    I run three WP multisites, each identical (but each used for different purposes) and running on the same version 3.3.1.

    One of them seems to have everything working correctly -- when I go to 'Add New User', I can select the role type in the drop-down menu. However, in the other two sites, the role menu appears, but with no options. I cannot select the role type because there are no roles to select. Why is this happening and how do I fix it so role types appear again?

    Another problem (minor), is in the top toolbar under 'My Sites', there should be 'Network Admin' and then after that, a listing of the multisites. In the same two sites that have the problem above, there is no such listing forcing me to go to the Network Admin sites every time in order to find the dashboard of the site I want to switch to. How do I fix it so the listing appears in this menu?

  2. Are you the admin of all sites?

  3. daseincog
    Member
    Posted 2 years ago #

    I'm the Superadmin for all sites.

  4. daseincog
    Member
    Posted 2 years ago #

    UPDATE: I found that next to my name in the Network Admin all users page, there were no sites listed under my name (or any other users' names). I manually added myself to the sites, and then they appeared on the Network Admin all users page (This also solved my second problem of having no sites listed under my 'My Sites' menu). However, if I go into the dashboard of one of the sites and view all users, no users appear. What's going on?? How do I fix this?

    I am very sure that once I am on the list of all users for each site, I will be able to add users and appoint roles, but right now I can't for some reason!

  5. Superadmin != admin for all sites :)

    SuperAdmin is the SuperAdmin. SITE Admin is added as SiteAdmin. That's how it's supposed to work.

    Have you added users to each site? By default, no one's added to a site.

  6. daseincog
    Member
    Posted 2 years ago #

    As I previously mentioned, yes, I ended up adding myself to as the admin user of each site. However, if I go into the dashboard of one of the sites and view all users, no users appear, despite the Network Admin all users page listing my access to all of the sites.

  7. You mean "no users, not even myself?"

  8. Go and add a test user. Testing it on yourself as a super admin ony clouds the issue.

  9. daseincog
    Member
    Posted 2 years ago #

    You mean "no users, not even myself?"

    Essentially, yes. Even though there are users that can access the individual sites.

  10. daseincog
    Member
    Posted 2 years ago #

    Go and add a test user. Testing it on yourself as a super admin ony clouds the issue.

    I added a new user to one site. The user shows up in the Network Admin users, but it doesn't show up in the site's users and I can't select the role type.

  11. Network Admin -> Settings "allow users to add other users".

    A user on the network will not show up on a subsite's user list unless:

    - you made them the admin when they created the site
    - or they were expressly added to a site with a specific role

    As a super admin or site owner you can go to SubSite -> Users -> Add New and "add from existing users".

  12. daseincog
    Member
    Posted 2 years ago #

    As a super admin or site owner you can go to SubSite -> Users -> Add New and "add from existing users".

    I did this also, and no role types appear.

    I want to make sure that from the start when I create user they are not given Admin, but Editor access. I can't seem to do this.

  13. You're not using custom roles, are you?

  14. daseincog
    Member
    Posted 2 years ago #

    You're not using custom roles, are you?

    No, I'm not using custom roles.

    I have three domains that run the identical setup of WP multisite, and while one of them seems to function properly (I can create users, see the listing of users in each subsite, assign roles, etc.) the other two cannot assign role types to new users and do not display in the 'all users' listing under each subsite.

  15. GrandMasterKD
    Member
    Posted 2 years ago #

    You can find the solution in this thread.
    Solution here...

Topic Closed

This topic has been closed to new replies.

About this Topic