WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Missing icons, template thumbnails, etc. (40 posts)

  1. bonniekirk
    Member
    Posted 5 years ago #

    I am attempting to run 2 wordpress installations from the same site. The first installation, running in the root directory, works fine. The 2nd is running under a different domain name, and points to a subdirectory. BOTH INSTALLATIONS ARE WP 2.7.

    The media icons are missing from the quickpress section of the dashboard and from add new post, edit post, add new page, and edit page. Oddly, even the WordPress icon is even missing from the upper left corner of every page.

    I've reinstalled WordPress multiple times, both with Fantastico and manually. I have:

    * checked for (and added) missing graphics in the wp-admin/images folder.

    * cleared cache multiple times and forced a reload multiple times.

    * enabled and disabled the visual editor numerous times, to no avail.

    * checked for missing *.js files in wp-includes/js/jquery. (In an earlier Fantastico installation, some were missing. Replacing them did not help. They were not missing from the manual installation.)

    I can duplicate the problem in IE7 and Google Chrome. My ISP's help support tried to troubleshoot using my login and password and reported, "I see the same issue using chrome under vista, but not with firefox under vista and linux. There isn't anything we can really do regarding this." However, since the problem also occurs with IE7, it's not strictly a Chrome issue.

    It's not impossible to use WordPress without these images, but it is difficult. And I'm reluctant to customize my theme. Help, please.

    Thanks,
    Bonnie

  2. bmedia
    Member
    Posted 5 years ago #

    I am having a very similar problem.

    Installation of 2.7 in a root domain working fine.

    New installation of 2.7 in an addon/subdomain, not working fine:

    -- missing WP logo on login-php page AND EVERY PAGE, actually!
    -- missing icons on edit post screen above where you edit posts ("Visual" mode)
    and, worst of all,
    -- incomplete graphical display of front page USING DEFAULT THEME. It's like it's MISSING (or not being able to execute?) some of the CSS or something. Background is all dark grey instead of pale grey with a white container for the posts, etc.
    -- all preview graphics missing from "Presentations -- Themes" page. (I.e., can't SEE what "default" and "classic" look like.
    -- "quickpress" area not displaying icons (just words)

    No plugins are installed here. The "images" folder IS installed and in the correct place on my server.

    Like the poster above me, I've now tried re-installing manually and by using Fantastico and I'm pretty familiar with WP, but no luck with this weird problem. Even tried changing permissions to 777. Nope.

    This is a brand new fresh 2.7 installation and it's all still set at DEFAULT everything.

    Ideas?

  3. Samuel B
    moderator
    Posted 5 years ago #

    are you both using the same database?
    if so, did you change the table_prefix for the 2nd installation to something different - as you should?

  4. ronitdeep
    Member
    Posted 5 years ago #

    I think i have same error..
    I have only one blog & not sharing databatase...
    I have tried multiple times...even by fantastico & manually..
    any idea??
    here it is
    http://mesotheliomatumor.info/wordpress/

  5. Samuel B
    moderator
    Posted 5 years ago #

    @ ronitdeep
    you have 2 installs
    http://mesotheliomatumor.info/wordpress/
    and
    http://mesotheliomatumor.info/word/
    they are sharing the same database
    if you want them both to work change the table_prefix in wp-config.php of one of the installs.
    Also you need to have the correct url settings (both of them) in your
    admin - settings for both blogs
    If you can't log in use this to correct the url's
    http://codex.wordpress.org/Changing_The_Site_URL

  6. bmedia
    Member
    Posted 5 years ago #

    Thanks for the response!

    I'm not using the same database; I created a new database just for the new install.

  7. Samuel B
    moderator
    Posted 5 years ago #

    @ kay9
    are the 2 url settings in
    admin - settings
    both correct?
    Also, try resetting the permalinks

  8. bonniekirk
    Member
    Posted 5 years ago #

    I do have one correction, however. The first installation, which is considered the root domain by my ISP, but the WordPress installation is in its own subdirectory off the root. The second also has its own installation in its own subdirectory.

    I know you were addressing a specific problem reported by @ronitdeep, but just in case:

    - The table_prefix = 'wp_' for both installations.

    - The URL's are correct on the General Settings page for both installations.

    Surely @kay9 and I are not the only 2 people running 2 different blogs.

    Thanks for any help you can provide.

  9. bonniekirk
    Member
    Posted 5 years ago #

    Just saw your permalinks suggestions, @samboll. I changed them to Day and Time. No images appearing yet.

  10. bmedia
    Member
    Posted 5 years ago #

    Tried the permalinks thing. Checked settings for URLs. Everything is as it should be. Still no icons, etc. and the front page of the default theme is STILL incorrectly rendered as I described above. Hmm.

    I'm about to uninstall all of it again via Fantastico, then check to be sure it's all really gone (via Cpanel). I guess I should delete the database and start all over there too. THEN maybe try reinstalling WP again. Don't know what else to try.

  11. figaro
    Member
    Posted 5 years ago #

    I'm about to uninstall all of it again via Fantastico, then check to be sure it's all really gone (via Cpanel).

    If you have Cpanel, once you get the fantistico install removed, then you may want to try installing manually.

    Written directons are here:

    http://codex.wordpress.org/Installing_WordPress#Detailed_Instructions

    If you are a visual learner, see a video here:

    http://educhalk.org/blog/?p=1

  12. bmedia
    Member
    Posted 5 years ago #

    Figaro, thanks, I've already installed it manually twice now. :-)

    Like the poster above me, I've now tried re-installing manually and by using Fantastico and I'm pretty familiar with WP, but no luck with this weird problem. Even tried changing permissions to 777. Nope.

  13. figaro
    Member
    Posted 5 years ago #

    @kay9

    You may have already said this, but I just haven't read through the entire thread...who is your host and are you on a linux or windows hosting?

  14. bonniekirk
    Member
    Posted 5 years ago #

    I'm on A Small Orange, currently hosted on a linux server.

    Bonnie Kirk

  15. bonniekirk
    Member
    Posted 5 years ago #

    ASO's Tech Support just provided this add'l info, if this will be helpful:

    We only use CentOS Linux on our servers. You're on the server "Sun" sun.asmallorange.com.

    CENTOS 5.2 x86_64
    We use cPanel 11 as our web host management software

    Bonnie

  16. figaro
    Member
    Posted 5 years ago #

    I'm on A Small Orange

    I've seen a lot of people recommend them here, so I'm sure they must have their servers configured to properly handle WP. If you're sure you are properly installing, then I'm not sure what else to recommend.

  17. bonniekirk
    Member
    Posted 5 years ago #

    aaarrrggghhh. Thanks for your help, though. If you've read through the first 2 posts in this thread, @kay and I have jumped through every hoop that anyone has suggested for problems that seem to be remotely similar.

  18. bonniekirk
    Member
    Posted 5 years ago #

    @kay, are you using Windows XP, Vista, or something else?

  19. ronitdeep
    Member
    Posted 5 years ago #

    @ samboll,

    thanks for your quick reply..

    I am newone @wordpress
    I have deleted my databases, deleted both blogs & reinstalled database aswell as blog..[only 1]
    still the same problem..

    http://mesotheliomatumor.info/wordpress/

  20. whooami
    Member
    Posted 5 years ago #

    my last shared host was a small orange. Their servers are set up properly for wordpress.

    kay9 and bonnie, you both fail to elaborate on what "missing" means..

    ... missing WP logo on login-php page AND EVERY PAGE, actually

    Its not displaying, thats fine - I want to know where wordpress thinks it ought to be. There's still urls attached to things that dont display.

  21. bonniekirk
    Member
    Posted 5 years ago #

    @whoami, I guess we have a semantic problem. I don't know what other words @kay and I can use besides icons and graphics. Specifically, to recap our first posts:

    - the WordPress logo graphic is missing from every page. That's not a usability issue, but it should be a clue to someone

    - the media icons are missing from the write and edit pages and the quickpress box on the dashboard page. The standard "missing graphic" symbol appears in place of each, so I have to rely on hover tips to tell me if I'm clicking on the right button. This is a usability issue

    - the theme thumbnails are missing, which would be a usability issue if I had not already chosen a theme.

    - The problems persist whether I use Chrome or IE7; my system is Windows XP. My ISP's Help Support recreated the problem with Chrome under Vista, but the problems do not exist with Firefox under Vista and Linux. (For some reason my computer won't run Firefox, or I would have already tried that.)

    - These things only happen on our second (newest) installations. The first installations are fine.

    I think we have pretty thoroughly documented our attempts to fix the problem.

  22. MichaelH
    Member
    Posted 5 years ago #

    Not that I can add much here, but can say that on three domains at ASO, I am having no problems with the logos, media icons (both in quickpress or edit posts), or theme thumbnails, using WordPress 2.7, with Firefox3.0.5 or IE6 on XP workstation.

    Did not use Fantastico on any domain and using different databases for each domain.

    Each blog is accessed with and index.php file in the domain's root folder, with the WordPress files in their own directory. Folder structure:
    domain1 public_html/wordpress
    domain2 public_html/domain2folder/wordpress (add-on domain)
    domain3 public_html/domain3folder/wordpress (add-on domain)

    I don't suppose clearing your browser cache, deleting cookies for all your domains at ASO, and first accessing one of those problem domains, makes a difference?

    [moderated]

  23. bonniekirk
    Member
    Posted 5 years ago #

    Michael,

    Thanks for the heads up about the contact form. Broken plugin, and my attempts to upload new version are taking forever.

    I can already see a difference. Neither the installation that works, nor the installation that doesn't are in in wordpress folders. Let me try deleting the installation that isn't working, and reinstall with a structure like you have.

    If problem continues, and I can get this plugin uploaded, I'll let you know.

    Thank you for your offer and assistance so far.

  24. bonniekirk
    Member
    Posted 5 years ago #

    I forgot to add, clearing the cache and deleting cookies did not work before, but I will try it again before reinstalling.

    Thanks.

  25. bmedia
    Member
    Posted 5 years ago #

    Bonnie -- try adding your new addon's domain name to your hotlink protection thingy in the cPanel. Worked for me!

    Add it with and without the www.

  26. bmedia
    Member
    Posted 5 years ago #

    Oh God I hope I'm not too late for Bonnie.

    Bonnie! Are you reinstalling? Wait! Wait!

  27. bonniekirk
    Member
    Posted 5 years ago #

    I got your message. will try that now. Thanks, kay9

  28. bonniekirk
    Member
    Posted 5 years ago #

    Bingo! PROBLEM SOLVED! I don't know how you figured this out, but I'm hoping something we documented here will get picked up by the search engines for other people.

  29. bmedia
    Member
    Posted 5 years ago #

    Bonnie: I can't take credit. I opened a help ticket with my OUTSTANDING hosting service and, as usual, they responded with the correct solution in about 1 minute and 30 seconds. I LOVE THEM.

  30. MichaelH
    Member
    Posted 5 years ago #

    Marking this as resolved,

    @kay9, could you tell us your host company name. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic