WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
Missing Download link below viewer (6 posts)

  1. Frank999
    Member
    Posted 1 year ago #

    Hi,

    i use the plugin version 2.4.6. When i add an pdf to show there is no download link below. Because i can not enter the GDE Settings (i stupid php error i don`t understand) i cannot look at the options. Is there a shortcut option to ensure that the download link is visible?

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    I'd like to know what the php error is all about, though 2.4.6 was rock solid and it may be a conflict from another plugin (just a guess). Using save="1" should allow the link to be shown even if it's not shown by default. But there is also a setting to show it only for logged in users, so depending on what that was set to, you may not be able to override it.

    It's possible to change the settings via direct database edit, but you need to know what you're doing or else WordPress is in a big mess. I'd suggest you need access to the settings page, whether by fixing the php error or installing the current version of the plugin, if the simple edit above doesn't work.

  3. Frank999
    Member
    Posted 1 year ago #

    I got the following error message when i try try to oben the settings:

    PHP Warning: is_readable(): open_basedir restriction in effect. File(C:\Inetpub\vhosts\xxx\httpdocs\wp/wp-content/plugins/C:\Inetpub\vhosts\xxx\httpdocs\wp\wp-content\plugins\google-document-embedder/languages/gde-de_DE.mo) is not within the allowed path(s): (C:/Inetpub/vhosts/xxx\;C:\Windows\Temp\) in C:\Inetpub\vhosts\xxx\httpdocs\wp\wp-includes\l10n.php on line 339

    I have also tried save="1" option but without any effect. The crazy thing is that with an previous version of the plugin i have seen this download links. The i have installed 2.5 and had trouble with it, so i step back to the older version. Since then the download link disappeered.

  4. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Did you completely remove 2.5 before reinstalling 2.4.x?

    Those errors don't mean anything to me, and seem odd given it references only a German language file and not the plugin itself. You may have other problems going on with your site that don't have anything to do with the plugin, but at the very least, I'd recommend a complete uninstall and reinstall. Your situation there is totally unique as far as I can tell.

  5. Frank999
    Member
    Posted 1 year ago #

    I have asked my provider about this error and they mean that there is an error in the plugin with building the path.

    I haven't any idea what is wrong here and i have no knowlegde of PHP or setting this system up and running.

    Have you any new idea with this new fact?

  6. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Frank,

    I would think your host has a peculiar open_basedir setting in their PHP config. open_basedir is meant to prevent you from accessing files on somebody else's site. Assuming the plugin is installed locally on your own web space, this error then makes no sense, and I've never heard of anyone else having the issue.

    Considering it's erroring out on a plugin language file, and not the plugin itself, I can't explain the behavior. If you're not using the German translation of the plugin, you can just delete the noted files from the google-document-embedder/languages folder and see if the problem is resolved.

    Kevin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.