WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Missing default user roles on 1 blog in multisite (5 posts)

  1. Jive Dig
    Member
    Posted 11 months ago #

    I'm not sure when they went missing. It's only one blog. My network is using Easy Digital Downloads, and the custom roles created by EDD are available. On all other sites users are registered as subscribers and I can add new users and set their role accordingly. On one blog, however, the only options are EDD's custom roles. Therefore, default users are being created as Shop Accountants. Not good!

    I don't need any custom capabilities for the default roles, I just want them to 'reset' or whatever I need to do to get them back.

    I read a few other threads about going through the database, but that seemed to be referring to tables created the old way... this install is subdomains and was just created on WP 3.5.

    Anyone care to help?

  2. You have need to ask this here: https://easydigitaldownloads.com/

    That's pretty specific to the plugin and I suspect has to do with how it's configured :/

  3. Jive Dig
    Member
    Posted 11 months ago #

    I don't think it has anything to do with EDD, but I can ask them as well. No other sites have this issue, and even with EDD disabled the default roles are still non-existent.

  4. If you used a plugin (EDD) to mess with the user roles, the odds are that's what did it.

    Disabling the plugins generally don't reset roles per site.

  5. Jive Dig
    Member
    Posted 11 months ago #

    I was something from User Role Editor plugin, even though I only used it for a day... I must've done something weird. I reset all the roles to default via a nice setting in that plugin.

    For anyone that cares... here's the support I received from the dev.
    http://shinephp.com/forums/topic/default-roles-missing-1-blog-multisite/

    Thanks for checking into it Ipstenu

Reply

You must log in to post.

About this Topic

Tags

No tags yet.