WordPress.org

Ready to get started?Download WordPress

Forums

"Missing Content-Type Header!" after upgrade (3 posts)

  1. fshk
    Member
    Posted 7 years ago #

    I was, granted, having some login issues before I upgraded, which I think I just made worse, but I thought reinstalling WordPress would fix the problem, and if I was reinstalling, I might as well upgrade, right?

    Well, I ran upgrade.php, and got a message that I had upgraded successfully, but now when I go to /wordpress/wp-admin/index.php, I get:

    STDERR:

    Invalid Header: [HTTP/1.1 302 Moved Temporarily]
    Missing Content-Type Header!

    STDOUT:

    HTTP/1.1 302 Moved Temporarily
    Set-Cookie: bb2_screener_=1181337955+24.45.4.146; path=/blog/
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Last-Modified: Fri, 08 Jun 2007 21:25:55 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Location: [my site]/wordpress/wp-login.php?redirect_to=%2Fwordpress%2Fwp-admin%2Findex.php
    Content-type: text/html

    Um, help.

  2. Firas
    Member
    Posted 7 years ago #

    Wow, that's bizarre. Are you the sysadmin on the hosting machine? Definitely something different about your setup. Is the http response being proxied somehow? I'd get in touch with the host just to see if they're familiar with what would have caused that sort of output.

  3. Brian Layman
    Member
    Posted 7 years ago #

    That is rather spectacular isn't it?

    I really don't think you have all of the files for 2.2.

    I would install them again. then if it still isn't up I would delete all theme directories except default and see what happens.

    Is it possible that you don't have the the required php and mysql versions for 2.2? The announcement shows the requirements...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags