WordPress.org

Ready to get started?Download WordPress

Forums

Social
Missing argument 5 for Social::get_avatar() (10 posts)

  1. msebald
    Member
    Posted 1 year ago #

    I'm getting tons of these errors in Apache error log:

    [Sat Dec 22 01:32:13 2012] [warn] [client 2a01:198:2b4::2] mod_fcgid: stderr: PHP Warning: Missing argument 5 for Social::get_avatar() in /var/www/clients/client1/web280/web/wp-content/plugins/social/social.php on line 1355, referer: http://www.domain.tld/wp-admin/options-general.php?page=social.php
    [Sat Dec 22 01:32:13 2012] [warn] [client 2a01:198:2b4::2] mod_fcgid: stderr: PHP Warning: Missing argument 5 for Social_Facebook::get_avatar() in /var/www/clients/client1/web280/web/wp-content/plugins/social/social-facebook.php on line 72, referer: http://www.domain.tld/wp-admin/options-general.php?page=social.php

    I do not have any Facebook settings in Social as I do not use it for Facebook.

    If you need any further information I am happy to provide these.

    Cheers,
    Martin

    http://wordpress.org/extend/plugins/social/

  2. ToniOR73
    Member
    Posted 1 year ago #

    I'm also getting those errors:

    Warning: Missing argument 5 for Social::get_avatar() in /home/tornrose/wherethehellarewe.com/wp-content/plugins/social/social.php on line 1355

    Warning: Missing argument 5 for Social_Facebook::get_avatar() in /home/tornrose/wherethehellarewe.com/wp-content/plugins/social/social-facebook.php on line 72

    Warning: Missing argument 5 for Social::get_avatar() in /home/tornrose/wherethehellarewe.com/wp-content/plugins/social/social.php on line 1355

    Warning: Missing argument 5 for Social_Facebook::get_avatar() in /home/tornrose/wherethehellarewe.com/wp-content/plugins/social/social-facebook.php on line 72

    I'm only getting that on one of my blogs, the other two are fine

  3. keeperbay
    Member
    Posted 1 year ago #

    Did it happen after you updated to 3.5?

    If so, try this: http://stuckathomemom.com/how-to/mini-posts/misc-mini-posts/a-quick-fix-for-wordpress-3-5-a-patch-job-really

    It's really only a quickly patch until all the plugins and themes are updated, but it seems to solve every 3.5 issue.

  4. msebald
    Member
    Posted 1 year ago #

    I am still using WordPress 3.42. ;-)

  5. keeperbay
    Member
    Posted 1 year ago #

    shucks!

  6. msebald
    Member
    Posted 1 year ago #

    Hm hello,

    did themaintainer notice that bug? I still have my error.log flooded with these messages.

    Plus it prevents WP-United from working correctly as I get error notices from it with the PHP warnings init. When I disable Social I can setup the options for WP-United.

    Cheers,
    Martin

  7. dverbrugge
    Member
    Posted 1 year ago #

    I don't have the error now, but when I installed this plugin:
    http://wordpress.org/extend/plugins/add-local-avatar I did get the error.
    I uninstalled the plugin and used another avatar plugin.

    Maybe this helps you, maybe not.

  8. dverbrugge
    Member
    Posted 1 year ago #

    By the way, this seems to be a known issue, and my contribution was already submitted by someone else ;)
    https://github.com/crowdfavorite/wp-social/issues/132

  9. msebald
    Member
    Posted 1 year ago #

    Thanks, that worked. I did have the avatar plugin running and I disabled it now. With WP-United there is not much need anymore for this plugin.

    But there is some problem/incompatibility here which maybe should be addressed.

    Thanks again! :-)

  10. Jonathan D. Johnson (jondavidjohn)
    Member
    Posted 1 year ago #

    Looks to be a known (and unresolved) issue with the add-local-avatar plugin.

    http://wordpress.org/support/topic/get_avatar-filter-hook-missing-5th-argument

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic