WordPress.org

Ready to get started?Download WordPress

Forums

Sliding Youtube Gallery
[resolved] Missing argument 2 for wpdb::prepare(), (6 posts)

  1. dnlsrs
    Member
    Posted 1 year ago #

    Hi!
    Since WordPress release 3.5, SYG 1.3.6 stop working.

    The following php warnings are displyed:
    Warning: Missing argument 2 for wpdb::prepare(), called in /home/ajamesp/public_html/wp-content/plugins/sliding-youtube-gallery/engine/SygDao.php on line 257 and defined in /home/ajamesp/public_html/wp-includes/wp-db.php on line 990

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/ajamesp/public_html/wp-content/plugins/sliding-youtube-gallery/engine/SygDao.php on line 244 and defined in /home/ajamesp/public_html/wp-includes/wp-db.php on line 990

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/ajamesp/public_html/wp-content/plugins/sliding-youtube-gallery/engine/SygDao.php on line 159 and defined in /home/ajamesp/public_html/wp-includes/wp-db.php on line 990

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/ajamesp/public_html/wp-content/plugins/sliding-youtube-gallery/engine/SygDao.php on line 244 and defined in /home/ajamesp/public_html/wp-includes/wp-db.php on line 990

    I tried to fix the SygDao.php but without success.

    Can anyone help me?
    Thanks!

    http://wordpress.org/extend/plugins/sliding-youtube-gallery/

  2. charmedlife
    Member
    Posted 1 year ago #

    I am getting the same thing: Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/95/3351895/html/wp-content/plugins/sliding-youtube-gallery/engine/SygDao.php on line 212 and defined in /home/content/95/3351895/html/wp-includes/wp-db.php on line 990

  3. webEng
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,
    Yes It’s a new Warning introduced in Wp 3.5. Take a look here:

    http://make.wordpress.org/core/2012/12/12/php-warning-missing-argument-2-for-wpdb-prepare/

    The plugin should work anyway, so if you are fed up about warning message please modify your wp-config.php as described in the article. You have to insert a line on the top like this:

    @ini_set('display_errors', 0);

    In the next days I will release a new version that should achieve the problem, even if it isn’t a real problem. If you have any trouble don’t exitate to contact me again.

    Thank you, Luca

  4. charmedlife
    Member
    Posted 1 year ago #

    mmm... seems like a "real problem" to me... I guess I did not explain it well enough. Here, take a look: http://gateslosangeles.com/youtube-gate-videos/

  5. charmedlife
    Member
    Posted 1 year ago #

    oops! It did not work until I edited wp-config as you said to do. Now that I have done that; yes, it is working. Thanks!

  6. dnlsrs
    Member
    Posted 1 year ago #

    Hi!

    Ok, the warning messages are gone (editing wp-config.php).

    BUT, when I try to edit any video gallery (video list, youtube user or playlist), the changes are not applied.
    In fact, all video lists are deleted from database.

    I tried to reinstall the plugin without success.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.