WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic Widgets
[resolved] Missing argument 2 for wpdb::prepare() (18 posts)

  1. dexpositoromero
    Member
    Posted 1 year ago #

    Broken, delivering error:

    Missing argument 2 for wpdb::prepare(), called in /home/content/92/10109692/html/wp-content/plugins/dynamic-widgets/classes/dynwid_class.php on line 654 and defined in /home/content/92/10109692/html/wp-includes/wp-db.php on line 990

    http://wordpress.org/extend/plugins/dynamic-widgets/

  2. gerobe
    Member
    Posted 1 year ago #

    This can be fixed by searching the file /classes/dynwid_class.php for the string

    prepare($query)

    and replace it with

    prepare($query,null)

    the string should be found twice in that file.

  3. dexpositoromero
    Member
    Posted 1 year ago #

    Thanks a lot, gerobe. Worked like a charm :)

  4. TxAggie08
    Member
    Posted 1 year ago #

    this worked for me.

    replace with

    function prepare( $query = null ) { // ( $query, *$args )
    if ( is_null( $query ) )
    return;

  5. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    I thought I already pushed a fix for that to the development version, but looking into it now, that's apparently not the case. Will do that asap.

  6. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    OK, fix is available in the development version.

  7. auckand
    Member
    Posted 1 year ago #

    I have the same error using the Sharebar plugin. Until the developers update their plugins try this in your function.php

    ini_set( 'display_errors', false );
    error_reporting( 0 );

    It stops error mesages and once the plugin devs update- just remove the code.

    Worked over at http://www.outdoorphotography.co.nz/ I hope this helps

  8. chevymanusa
    Member
    Posted 1 year ago #

    Hello Gerobe, TxAggie08 and Qurl.
    I am asking something rather unorthodox and that is if you guys might be so willing/open/awesome to take a look at my post regarding a rather similar issue with wordpress 3.5. Different plugin, similar problem. I tired messing around with it but had no luck.

    Yes, I know this is a different plugin and this forum is for this plugin.
    However, You guys seem awesome, look like you know your way(s) around plugins and figured I would give this a shot.

    Plugin in question: WordPress Popup
    http://wordpress.org/extend/plugins/wordpress-popup/

    Link:
    http://wordpress.org/support/topic/v-432-spits-out-errors-with-wordpress-35

    Thanks in advance!

    Regards,
    Chevyman

  9. gerobe
    Member
    Posted 1 year ago #

    Hi chevymanusa,
    I have seen, that you already could fix this the same way. Great.

  10. Shillos
    Member
    Posted 1 year ago #

    this is an error i have been having. just hope its going to be updated soon!

  11. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    Please see a few posts before, some 12 hours ago. It's fixed in the latest development version.

  12. chevymanusa
    Member
    Posted 1 year ago #

    Thanks for the support and pardon the thread jacking.

    You all have a wonderful day!

  13. PaulSHill
    Member
    Posted 1 year ago #

    Adding "null" to the query solved it nicely for my site.

  14. jren
    Member
    Posted 1 year ago #

    I have some problem: Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/82/9592282/html/shop/wp-content/themes/classipress/index.php on line 85 and defined in /home/content/82/9592282/html/shop/wp-includes/wp-db.php on line 990

    I don't know how to fix it,

  15. jren
    Member
    Posted 1 year ago #

    I have same problem: Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/82/9592282/html/shop/wp-content/themes/classipress/index.php on line 85 and defined in /home/content/82/9592282/html/shop/wp-includes/wp-db.php on line 990

    I don't know how to fix it,

  16. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    The warning occurs in the classipress theme. Please contact the author of the classipress theme. This topic is about the same warning in the Dynamic Widgets plugin and has been resolved.

  17. dokan216
    Member
    Posted 1 year ago #

    Running Dynamic Widgets 1.5.4 and getting this error:

    preg_match() expects parameter 2 to be string, array given in

    The error appears in the "Random Quote" widget of the "Quotes Collection" plugin.

    Please help?

  18. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    This topic is about a different warning and has been resolved. Please open a new topic and state in which file and on which line this error occurs.

    There must be more information after the word "in". Something like "/this/directory/and_this_file.php on line 3"

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.