WordPress.org

Ready to get started?Download WordPress

Forums

Missed Schedule (92 posts)

  1. chrisgiddings
    Member
    Posted 5 years ago #

    I found a simple workaround for this. Not long-term to be sure...

    Simply revert the post from scheduled to "Draft", then Publish the post again. Boom! You have a posted article.

    I am running 2.7.1

    I have been running this installation of WordPress a little over a month on a brand new blog without issues until this morning. My blog remains young enough that I am paying very close attention to the three weekly posts I currently make.

    I hope this helps everyone until the WordPress team fixes this issue.

  2. WebmasterDylan
    Member
    Posted 5 years ago #

    It took me a while to figure it all out... nothing seemed to be working in my case!

    but...

    The solution posted before; replacing the 'wp-cron' and 'cron' file is partly working: it's working for all the 'new' scheduled posts (scheduled after the replacement). All the posts which have been scheduled before replacement of those files will still be marked as 'missed schedule' in the future.

    The (only) solution to avoid that is like chrisgiddings showed: draft and then publish again.

    So if you've got many posts scheduled, make an export of your WP-blog, replace the cron and wp-cron files, import your blog again!!

  3. MichaelH
    Member
    Posted 5 years ago #

  4. mike
    Member
    Posted 5 years ago #

    I am having a similar problem on my server. However, scheduling workings for a blog hosted at:

    http://domain.com/blog
    http://domain.com/blog2

    but fails at both:

    http://sub1.domain.com/
    http://sub2.domain.com/

    All run 2.7.1 and all receive 100s if not 1000s of hits an hour.. Could the PHP settings differ on the subdomains?

  5. Hendison Scott
    Member
    Posted 5 years ago #

    Just ran across this thread after a client complained of the same issue today. I logged into their 2.71 blog to examine, but they only have a pending one scheduled for 10 hours from now, so either they manually posted it themselves - or - it's going to be a problem again tomorrow.

    So, at this point, there are apparently still people having this problem on 2.71 - so now what, with no wp-cron to replace?

  6. bottleneck
    Member
    Posted 5 years ago #

    in my particular case "Missed Schedule" warnings disappeared after a sysadmin synchronized the internal server-set time and the real atomic clock's time. It was a two minutes discrepancy.

  7. drkameleon
    Member
    Posted 5 years ago #

    @jadebydesign:

    Many thanks!

    Your solution works!!!

  8. Shyzer
    Member
    Posted 5 years ago #

    In case this helps any...

    I've been running 2.7.1 for a while and scheduled posts were never a problem. Then I switched to a dedicated server, moved my site, and all of a sudden I was getting the orange "Missed Schedule" message. I tried jadebydesign's solution, but it didn't work for me. Looking forward to this getting fixed in 2.8!

  9. laethyn
    Member
    Posted 5 years ago #

    Oddly, the problem I had with mine after the upgrade was that the post_status (wp_posts table) enum was missing the 'future' option.

    I modified the post_status enum using the following:

    ALTER TABLE wp_posts CHANGE post_status post_status ENUM('publish','draft','private','static','object','attachment','future') CHARACTER SET latin1 COLLATE latin1_swedish_ci NOT NULL DEFAULT 'publish'

    via phpmyadmin

    posts are now appearing in the list of editable posts, and all scheduled posts are now appearing on time.

    Cheers,

    Laethyn

  10. kirk34
    Member
    Posted 5 years ago #

    How I fixed my missed schedule problem, works fine now.

    My blog was effected by the new WordPress wp-cron.php internal cron system. There are two ways to get around this... a) Install a plugin that will trigger wp-cron every so often (although I do not recommend this). b) Set up a cron job to load your blog every so often. Personally, on my blogs, I use a cron job to load them once per hour. This ensures that wp-cron will trigger at least once per hour. The easiest way to set this up would be:
    26 */1 * * * /usr/bin/lynx -dump http://www.yourdomain.com > /dev/null

    This would access your site once per hour, and will dump the page to /dev/null so you will only receive an e-mail on error.

    There was a bug reported, sometime in the past few months, where wp-cron would not trigger properly at times. In other words, if the trigger was too far after the scheduled time, it wouldn't process.

    Hope this helps, it helped my blogs scheduled time problems.

  11. serenebalance
    Member
    Posted 5 years ago #

    We just started having this problem.

    We created our blog ~6 months ago w/ Blogger, then imported directly into WP v2.7.1, but JUST NOW started having this issue, for no reason that is apparent to us.

    As suggested in this thread, we tried updating the cron and wp-cron files w/ the ones from v2.6.5, but this did not work.

    I am wondering whether this issue was caused by a recent update to a plug-in (and if so, which one?), or something our webhost might've changed.

    If anyone has ideas, we'd be extremely grateful for help, as we publish in the wee hours of the morning and don't want to have to do this manually!

  12. Shyzer
    Member
    Posted 5 years ago #

    For the record, I never did find a solution to this problem with WP 2.7.1. However, upgrading to WP 2.8 did the trick and now scheduling works fine on my site.

  13. Alber
    Member
    Posted 5 years ago #

    Having 2.7.1 and 2.8 on the windows hosting. Problem exists for both cases. Any updates on how to fix that?

  14. stelling
    Member
    Posted 5 years ago #

    The issue still persists on 2.8, the only workable solution so far is to revert back to version 2.6.5 wp_cron.php and wp-includes/cron.php as indicated by Jadedbydesign:

    I found a solution to this problem but it's nothing like what's been proposed here already. My web host doesn't allow for changes to php.ini by its users and I know nothing about curl and such.

    So to make a long story short I decided to put up a test of WordPress 2.7 on a test domain and I exchanged two files from WordPress 2.7 with two files from the last version of WordPress 2.6.5

    The files exchanged on my server were wp-cron.php and cron.php

    All I did was log into my FTP and upload the wp-cron.php to my WordPress root and the cron.php had to be uploaded to the folder "wp-includes".

    Not only are my posts publishing on schedule but the 6 posts I had that had "Missed Schedule" were published as well when I refreshed my blog.

  15. Nt3N
    Member
    Posted 5 years ago #

    hello all.

    after I moved my blog (wp 2.8) to a new server I got this issue.
    I tried most of the solutions you can find on google searches:

    1. use cron files from wp 2.6.5/2.7 -> DOESN'T WORK
    2. check the etc/host file -> WAS CORRECT
    3. use wp-crontrol -> DOESN'T WORK WELL

    what I figured out is that the cron jobs are somehow blocked by PHP Safe Mode setting. I disabled it, and it works now.

    But can anyone find the right parameter to change, so I can keep PHP Safe Mode On and schedule my posts as well?

  16. dcrisc
    Member
    Posted 5 years ago #

    I had a problem with missed posts and found the following plugin which worked!!

    Scheduled MIAs

    Just copy the code, create a file called mias.php, and put the file in your plugins folder. Active it thru the dashboard and voila!

  17. FCGrabo
    Member
    Posted 5 years ago #

    This fix worked for me.
    http://wpengineer.com/ping-problem/

    I also got rid of the WP-Cache plugin and added the WP-Supercache plugin.

  18. cookeal
    Member
    Posted 5 years ago #

    My host provided patched cron files for 2.71 which got around the cron problems - currently not working for 2.8 but have posted a tcket asking that someone with more knowledge than me takes a look at incorporating the files.

    http://core.trac.wordpress.org/ticket/10353

  19. Alber
    Member
    Posted 5 years ago #

    2.8.1, windows hosting. Instead of scheduling future posts get published immediately.

    It's most simple & stupid WP bug I have ever seen.

  20. Brad Touesnard
    Member
    Posted 4 years ago #


  21. Brad Touesnard
    Member
    Posted 4 years ago #

    If you are hosted on Media Temple (dv) or using Plesk, I've written a blog post describing the problem and how to fix it. Check it out.

  22. Alber
    Member
    Posted 4 years ago #

    2.8.2, IIS, nothing changed.

  23. kristapley
    Member
    Posted 4 years ago #

    How exactly is it acceptable that WP hasn't addressed this? Jesus.

  24. Urosino
    Member
    Posted 4 years ago #

    Beside that cron is no longer working properly, I assume it's causing WP load slow, especially first page load.

    Any possible solutions guys, beside those posted.

  25. vijaay3d
    Member
    Posted 4 years ago #

    Hi,
    I've have a external program which dumps value into "wp_post" and "wp_term_relationships" table with
    "wp_post"."post_status" field as "future"
    "wp_post"."post_date and" "wp_post"."post_date_gmt" with a scheduled date.

    Scheduler is working fine when i do new post using admin panel, but does work when i do from external program? It get missed. but when i edit and update the post with it works.

    Any one tried creating post from external program? do i need to store post value to any where else other that "wp_post" table?

  26. Russell Cohen (Mywebapps)
    Member
    Posted 4 years ago #

    This is absolutely shocking! From what I understand, this got “broken” with WP 2.7. We’re now on WP 2.8.4(!) and this documented bug remains unresolved.

    I’m planning to install the plugin below from 5ubliminal to see if that resolves it.

    “Missed Schedule” Future Posts - Scheduled M.I.A.s WordPress Plugin 5ubliminal’s 5pace

    Apart from that, backrevving or editing your cron stuff (which I’m not comfortable doing) appears to be the only way out until Automattic gets their act together and starts listening to users.

  27. Marlimant
    Member
    Posted 4 years ago #

    I have solved to the problem of missed scheduled:

    - First I recognized that wordpress 2,8 is much more slow, is a fact.
    - Then I stopped looking for an error of programming. I started to find an excessive delay.
    - Then, reading, I discovered that schedule post was not a problem of WordPress 2,8 it is a symptom of a slow system.
    - Finally I found it the solution here: http://lists.automattic.com/pipermail/wp-trac/2009-January/038071.html and consists of modifying the timeout in wp-includes/cron.php.
    Approximately in the line number 205 I changed
    wp_remote_post ($cron_url, Array (' timeout' => 0.01, ' blocking' => false));

    To 20 seconds:

    wp_remote_post ($cron_url, Array (' timeout' => 20, ' blocking' => false));

    Lamentably I have not get to scheduled post work nex to Hyper Cache (they only works together in WP 2,6) reason why you must to disconnect that plugin to see working scheduled post.
    It's work for me. I hope help you.

  28. Russell Cohen (Mywebapps)
    Member
    Posted 4 years ago #

    If you are planning to make use of the Scheduled MIAs (Missing In Action) WordPress Plugin I referred to in my previous reply, please read this blog post first, especially if (like me) you’ve no idea what to do with this piece of raw PHP code!

    WordPress: Missed Schedule for Scheduled Posts - A Plugin Fix | (Anti) Social Development

  29. dh
    Member
    Posted 4 years ago #

    I am running WordPress 2.7 (we need an upgrade) on IIS 7, we host ourselves. We had the scheduling problem and I found a solution that worked.

    http://www.kimwoodbridge.com/scheduled-posts-in-wordpress-dont-work-a-possible-solution-for-iis/

    Now the bit to change was slightly different (must be the different WP versions), but it still worked.

    Around line 180 of /wp-includes/cron.php is the following
    $cron_url = get_option( 'siteurl' ) . '/wp-cron.php?check=' . wp_hash('187425');

    we change to:

    $cron_url = 'http://127.0.0.1/wp-cron.php?check=' . wp_hash('187425');

    and scheduled posts now work.

    I hope this helps someone else

  30. Russell Cohen (Mywebapps)
    Member
    Posted 4 years ago #

    Just to report back to the forum that 5ubliminal’s Scheduled MIAs (Missing in Action) WordPress Plugin did absolutely nothing (at least with my combination of WP 2.8.4, Thesis 1.5.1 and about 18 or so plugins). I guess it’s a case of “your mileage may vary”.

    http://wordpress.org/support/topic/221086/page/3?replies=89#post-1197666

    http://wordpress.org/support/topic/221086/page/3?replies=89#post-1197804

    The search for a solution goes on. I’ll try back revving the cron files next. That seems to have been the most successful suggestion thus far.
    --
    http://blog.maskil.info/

Topic Closed

This topic has been closed to new replies.

About this Topic