WordPress.org

Ready to get started?Download WordPress

Forums

124

Missed Schedule (92 posts)

  1. stelling
    Member
    Posted 5 years ago #

    Hi.
    I've started with a brand new 2.7 install importing posts from a "previous life". After a few days I noticed that all my imported scheduled posts missed schedule.

    I've created new versions of those posts and also created a new oneoff the cuff post to be published today.
    No scheduled post was published and now they're flagged with "Missed Schedule".
    I'm running 2.7-beta3-9851

    Any pointers ?

  2. stelling
    Member
    Posted 5 years ago #

    Here goes a dump of my wp_options table

    (removed by moderator - we really don't need your options table.)

  3. Posts scheduled before the upgrade seem to be missed, but all posts scheduled POST upgrade seem to be okay.

  4. stelling
    Member
    Posted 5 years ago #

    Actually posts scheduled after the upgrade still show as missed schedule!
    This is what happened this morning: I've created a new post (not an imported post) and scheduled it for 8AM this morning, at 8:30 it showed up as missed schedule. I had to make this post private and then public to have it published on the blog.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Install the WP-Crontrol plugin. It will let you manually run those missed wp-cron jobs to force the publish to work. And you really do need to run them, even if you already published them manually. That will get rid of the cron jobs, at least.

    Then you can start investigating why your wp-cron is not running properly. Usually this is a webserver configuration issue.

  6. stelling
    Member
    Posted 5 years ago #

    I've installed WP-Crontrol but it says that it's compatible up to 2.5.1, not 2.7.
    After install I got the following warning message:
    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in ..\wp-content\plugins\wp-crontrol\wp-crontrol.php on line 290

  7. stelling
    Member
    Posted 5 years ago #

    Anyway, I've installed WP-Crontrol, got rid of old events and uninstalled WP-Crontrol.

    Now, how can I verify if this is a webserver config issue or not ?

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Now, how can I verify if this is a webserver config issue or not ?

    If you make a new post and some "do_pings" events show up in WP-Crontrol and never go away, then it's a webserver config issue.

  9. perfectlyclear
    Member
    Posted 5 years ago #

    Getting the same issue here, I also got the same issues with 2.6 and above. I read somewhere not long ago that this issue with apparent cron server configuration issues would be fixed. I get the error on several different hosting accounts and all of the hosts swear blind their config is correct. I have seen multiple threads about this issue and multiple fixes and I am assuming the same issues are still here with 2.7 other than at least the admin panel tells you the post has not been published by tagging it "Missed schedule"

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    I read somewhere not long ago that this issue with apparent cron server configuration issues would be fixed

    Improved, not fixed. 2.7 uses the new HTTP API, which is more adept at actually being able to connect to things (it doesn't rely entirely on fsockopen anymore), but a broken host is a broken host, and WordPress can't "fix" what is not WordPress's problem.

    I get the error on several different hosting accounts and all of the hosts swear blind their config is correct.

    They are mistaken. The only way the wp-cron jobs can't run is a) nobody is looking at your site (including you in the admin screen) or b) the site itself is unable to make a connection back to its own URL with wp-cron.php appended to it.

  11. nslatter
    Member
    Posted 5 years ago #

    I'm having the same problem. That said, I've three different sites all of which use scheduled posting and are located on the same server. Two of them work, one of them doesn't. What do I need to look at in this case?

  12. nslatter
    Member
    Posted 5 years ago #

    update: I installed another instance of WordPress just to test -- and that install doesn't work either...

  13. stelling
    Member
    Posted 5 years ago #

    Now, how can I verify if this is a webserver config issue or not ?

    If you make a new post and some "do_pings" events show up in WP-Crontrol and never go away, then it's a webserver config issue.

    You mean any kind of post or a scheduled post ?

  14. stelling
    Member
    Posted 5 years ago #

    No cookie for me: I've created a new post and no "do_pings" events showed up in WP-Crontrol. The post is showing as "Missed Schedule".

    Another question: is this an exptected message "Warning: array_merge() [function.array-merge]: Argument #1 is not an array in ..\xadrez\wp-content\plugins\wp-crontrol\wp-crontrol.php on line 290" ?

  15. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    You mean any kind of post or a scheduled post ?

    Regular post, not a scheduled one.

    As for the error message, I think WP-Crontrol just has some minor issues. I usually turn off the PHP Warnings on my production sites though.

  16. stelling
    Member
    Posted 5 years ago #

    I've posted a few regular posts, just one do-ping showed up and it is still there. Is it normal ?
    Do you know where I can find the webserver requirements/specification for WP ? I will try to check with my provider but need to understand the rationale behind the requirement before talking to them.

  17. nslatter
    Member
    Posted 5 years ago #

    Do you know where I can find the webserver requirements/specification for WP ?

    This would help me as well. I took a huge step in doing VPS hosting a week or so back so can do whatever I want to the server. Thanks!

  18. Austin Passy
    Member
    Posted 5 years ago #

    I am having the same problem with scheduled posts. They just say "missed schedule".

  19. masya2000
    Member
    Posted 5 years ago #

    I have the same problem. I have 2 blogs on the same hosting 1 is working and another is not working - missed schedule. I don't thinks that it is the hosting problem

  20. arturogoga
    Member
    Posted 5 years ago #

    I'm having the same issue. My blog worked fine with 2.6.x and scheduled posts. Since upgrading to 2.7 (final) though, I keep getting the "Missed Schedule" error.

    No viable solution yet?

  21. chefben
    Member
    Posted 5 years ago #

    I am seeing this as well.

    Benjamin

  22. tinnov
    Member
    Posted 5 years ago #

    Ummm... All the requirements page says is that the software needs PHP 4.3 or greater, MySQL 4.0 or greater, and mod_rewrite support.

    Well, my server has all three of those things and the jobs still don't run. When you say it is a server configuration problem, could you please be more specific and less cryptic?

  23. PapaX2
    Member
    Posted 5 years ago #

    Count my vote for another site that can no longer schedule posts "missed schedule." This issue did not occur until I upgraded to 2.7 as well. Looking for a fix for this unexpected problem.

    Any ideas?

  24. PapaX2
    Member
    Posted 5 years ago #

    Seems to me that there may be some confusion around the post time when you are creating/scheduling a new post. It appears to be UTC and NOT your adjusted LOCAL time. I believe that the previous WP versions displayed our "local" time. In my particular case my time is -6 UTS to correct for local time. In any case, no matter what I do it still does not work. Once the scheduled time passes, the post converts to a DRAFT status.

    Good grief.

  25. bcreighton
    Member
    Posted 5 years ago #

    I'm having the same issue. Is there anything I can do?

  26. intended
    Member
    Posted 5 years ago #

    for all who is having this same issue, please see these docs. sivel in #wordpress was kind enough to point me in the right direction and i followed these docs and sure enough, no more missed schedules.

    altho i hear this should be fixed with 2.7.1 - thank god.

    http://trac.wordpress.org/ticket/8622

    when i first made those changes, it still did not work at first. so i followed the instructions at the next link and i was all set to go

    http://trac.wordpress.org/ticket/8590

  27. Paul Havemann
    Member
    Posted 5 years ago #

    And I'm another one for whom 'Missed schedule' is not a welcome sight.

    altho i hear this should be fixed with 2.7.1 - thank god.

    Yes, indeed, for those of us for whom the 'tickets' fix is just so much g(r)eek.

    I suppose the only real fix is to delete the post and re-post it in real time.

  28. Harvey
    Member
    Posted 5 years ago #

    I'm also not liking this "missed schedule" stuff. Hope this is fixed soon.

    I also was using scheduling without any issue before upgrading to 2.7.

  29. stelling
    Member
    Posted 5 years ago #

    @intended
    I've just tried disabling curl, as proposed here:

    when i first made those changes, it still did not work at first. so i followed the instructions at the next link and i was all set to go

    http://trac.wordpress.org/ticket/8590

    Now let's see if this does the trick...

124

Topic Closed

This topic has been closed to new replies.

About this Topic