WordPress.org

Ready to get started?Download WordPress

Forums

Minimum priv_type settings for secure MySQL setup (1 post)

  1. publicityship
    Member
    Posted 7 years ago #

    For a WP installation, I'd like to grant the MySQL user only the database privileges actually required to run WordPress.

    So instead of using:
    grant all on wpdb.* ... etc
    I want to use:
    grant [only required priv_types] on wpdb.*

    Are the minimum priv_type requirements documented anywhere? I have searched, but can't find. I understand some plugins may have special requirements, however figure the core WP 2.1 must have a core set of minimum requirements. Core priv_types such as select, insert etc are fine, its the less obvious ones such as reload or execute that would be worth knowing whether they are required.

    Version: MySQL 4.1.20

Topic Closed

This topic has been closed to new replies.

About this Topic