WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Minify is broken in latest version of W3TC 0.9.3 (14 posts)

  1. roam92
    Member
    Posted 10 months ago #

    W3TC no longer handles minification of our JS and CSS files correctly.

    The files get minified as before, but do not get removed from the page output!

    So consequently our site's pages have major duplication - the original JS/CSS files still remain in there, plus now they also have the minified versions included as well... Not helpful.

    It worked perfectly before upgrading from the old 0.9.2.4 W3TC version (using Manual configuration), so something new has been introduced since then to make minify no longer work properly.

    We had to disable W3TC's minify function and add/use the separate WP-Minify plugin instead to get our site output working right again.

    For more, see this thread:

    http://wordpress.org/support/topic/bug-after-minify-old-css-files-still-output-to-page

    http://wordpress.org/plugins/w3-total-cache/

  2. dfumagalli
    Member
    Posted 10 months ago #

    This was already posted by me in the recent past on the:

    Beware, don't update to 0.93, found massive issue in the generated code!

    I suggest everyone to ALWAYS read the W3 Total Cache support threads before upgrading.
    For most mods this is not needed at all, but you can never know with W3TC, and you know how devastating this mod can be.

  3. roam92
    Member
    Posted 10 months ago #

    Thanks for another confirmation. I did try to read the support forums first, but it's a lot and there always seem to be some reported problems with this plugin of late... After waiting a long time, this latest release seemed more safe to upgrade to from our old 0.9.2.4 than some of the other recent versions.

    Our workaround for now was to turn off minify in W3TC and go back to the separate WP-Minify plugin, which is what we used before moving to W3TC two years ago. This is a duplication of functionality behind the scenes but it works and avoids duplicating the CSS/JS code output, and seemed easier and less risky than a W3TC downgrade.

    The problem is, W3TC has gotten so complex and there is such a spate of ongoing reported problems that I'm not sure even the developers have a good handle on how to fully stabilize it, much less read or respond to all the support queries here...

    My hope would be the developers work on patching existing bugs and providing a minor fix-only release soon than try to add more features. This thing needs to finally get back to "Works!" status for most everyone on the WP plugin page - please!

  4. dfumagalli
    Member
    Posted 10 months ago #

    I fear the W3TC developer over-extended and got victim of his own success.

    I suppose when you get all those fortune 500 customers demanding priority support it becomes harder to keep up with the freebie guys sitting on WP.org and their issues.

    My only hope is that the "upgrade to pro" is not the magic word that will be a requirement to see anything done in the future. Because it will backfire.

  5. roam92
    Member
    Posted 10 months ago #

    The statistics now for version 0.9.3 on the main W3TC plugin page continue to be problematic:

    27 people say it works.
    19 people say it's broken.

    with:

    34 of 380 support threads in the last two months have been resolved.

    Aside from WP-Minify which we're now using instead, are there any other good alternatives to W3TC, that do most of what it does?

  6. almooj-craig
    Member
    Posted 10 months ago #

    I recently started using 0.9.3, first on a new 3.6 single user after getting it configured it works correctly with minimize.

    Then I did a manual upgrade on a 3.1.3 by first renaming the W3TC directory and then installing the new files from the 0.9.3. Minimize works fine.

    I also had an old 2.7mu where I tried to get 0.9.3 to work but had too many missing functions and fatal errors, so I upgraded 2.7mu to 3.6 and then manually installed 0.9.3 and minimize works fine on all of the different blogs, they also all run different templates.

    So to sum it up that's 3 diverse uses of 0.9.3 that work correctly with minimize.

    Perhaps you have a configuration problem or there is some leftover file from when you upgraded?

    Craig

  7. roam92
    Member
    Posted 9 months ago #

    Thanks a lot for your response. We upgraded from an older version of W3TC, I think it was 0.9.2.4 - which was the stable version for a long time.

    After moving up to 0.9.3, we did not remove or rename any of the W3TC files or directories under wp-content/ because there was no instruction to that effect, and if that needs to happen then the upgrade process should do it itself, right?

    But are you saying now that those directories or files can or should be deleted manually for this plugin to potentially function correctly? Is that even safe to do, and how would/should a user know? If so, it seems a glaring omission to the process.

  8. almooj-craig
    Member
    Posted 9 months ago #

    I have never used an automatic upgrade for plugins or WP. Normally the way I do it is to deactivate the old plugin. Then rename the old plugin directory by adding the version after the directory name. Then I unzip the plugin files and manually install them into the wp-content directory.

    I think for W3TC I also manually removed the cache directories, so that there would be no old cache files lurking around.

    Then I activated the W3TC plugin and configured it. Once I got the correct mod_rewrite installed in the virtual host, minimize worked correctly and enhanced page cache also worked correctly on all of the installations. A couple were upgrades from an older W3TC and one was a Super Cache. Once everything works correctly I remove the old directory from the server.

    If you don't feel comfortable trying that method, then just use the older version until the next W3TC comes out. You should also have a backup before you modify the site.

    Craig

  9. djeyewater
    Member
    Posted 9 months ago #

    For me the latest version of W3TC didn't work at all. It was listed in the plugins list in the Network admin panel, but didn't appear in the plugins list for any blogs. (This is with WPMU). For one of the blogs that had previously had W3TC enabled, there was an entry in the menu for W3TC, but the settings page was missing all the settings.

    I've downgraded to 0.9.2.4, but having minify switched on for css and js makes the site really slow. It's not regenerating the cached minified files on each page load, so I don't know what the issue is.

  10. tarheel83169
    Member
    Posted 9 months ago #

    9.3 works well for me but I would suggest completely bleaching the root directory of all .bak files and especially the w3totalcache_config file ... and install 9.3 clean. As for minify ... if you're having trouble with a dynamic site not displaying correctly it's advisable to remove any jquery strings from the js minify. If the problem continues I would suggest disabling minify completely in W3 and install WPminify ... it handles the compression and combining process much easier and does not conflict with W3 ... the two plugins working together wonderfully. I currently have both running on my DCX news blog.

  11. pepe
    Member
    Posted 6 months ago #

    To update this topic: 0.9.3 apparently only removes the file from the output if the fully qualified URL matches (including protocol and hostname) :(

  12. roam92
    Member
    Posted 6 months ago #

    Thanks, but it still is not working. The fully-qualified URLs do match but W3TC continues to duplicate the CSS & JS files in the output, rendering the function useless.

    There is no CDN or other service happening, but minification is still not doing its job.

    We tried completely uninstalling the W3TC plugin and all its files & directories, and then reinstalling it (per tarheel's and almooj's suggestions above) - but unfortunately that didn't help either. Same exact problem.

    Bottom line:
    We still have to turn W3TC's Minify completely off and use the additional WP-Minify plugin instead!

    Another poster said code added to the 0.9.3 release causes this problem:

    http://wordpress.org/support/topic/some-css-files-not-getting-minified

    We have not tried the suggested fix yet as any changes to the code should really come from the plugin developer.

  13. pepe
    Member
    Posted 6 months ago #

    I have tried removing the lines mentioned in the other thread that does in fact fix minify. However, I too have switched to another plugin for minification (AssetsMinify, which allows me to use SASS/COMPASS).

  14. roam92
    Member
    Posted 2 months ago #

    Greetings all,

    Has anyone tried the 0.9.4 update to W3TC yet to see if the JS/CSS minification duplication issue in 0.9.3 was fixed, or any other problems with it?

    Thanks

Reply

You must log in to post.

About this Plugin

About this Topic