WordPress.org

Ready to get started?Download WordPress

Forums

WP Fastest Cache
[resolved] Minify CSS still problematic (28 posts)

  1. Kramarz
    Member
    Posted 4 months ago #

    Hi mate,
    There's still some problem when Minifying CSS.
    Here's a example website for you to inspect - http://www.fivestarcleaning.ie/

    I will leave it like that for a while for you to take a look, will remove the plugin or switch off CSS minify after that.
    At the Very bottom there's a widget 'Get in Touch'. Third phone number is a fax number which should have a fax icon by it.

    The background CSS for a DIV that it sits in should be
    background: url("/wp-content/uploads/fax-icon.png") no-repeat scroll 0 9px rgba(0, 0, 0, 0);

    Unfortunately it gets broken by your plugin, so it is now
    background: url("../../../themes/freshbiz-child//wp-content/uploads/fax-icon.png") no-repeat scroll 0 9px rgba(0, 0, 0, 0);
    as you will notice.

    Any advice on how to fix it until you will fix the Minify CSS option?

    Kind Regards

    https://wordpress.org/plugins/wp-fastest-cache/

  2. Kramarz
    Member
    Posted 4 months ago #

    I think the issue is related to having a child theme and pulling some background images from the images folder within child theme?

  3. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    this is expected issue. Often designers put the style files into "theme" folder. but you put it into "upload". If you put your icon into "/themes/freshbiz-child/fax-icon.png", the problem is fixed.

  4. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    closed

  5. Kramarz
    Member
    Posted 4 months ago #

    So you're saying that with your plugin I can't put images that I use for styling in upload folder if I find it convenient?

  6. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    yes exactly. images must be in the /wp-content/theme/your-theme/

  7. Kramarz
    Member
    Posted 4 months ago #

    Well mate,

    I guess it's your plugin, do what you like :-)

    But I don't have this kind of issues when I use other caching plugins.
    My CSS styling images can be pulled from where ever I like them to be pulled.

    I left your plugin installed on the website mentioned here, but I just spent an hour fixing all the images that were uploaded to uploads folder to be in 'images' folder of the child theme instead and changing css background urls for them :-(

    I think you may want to reconsider a small fix for that. For me sometimes it's easier to simply upload through WordPress images I want to use for css and add urls in stylesheet accordingly.

    But maybe that's only me :-(

  8. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    you are right but worpress is a framework and we need to use properly.

  9. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    Hi again Kramarz, I will solve this issue.

  10. Kramarz
    Member
    Posted 4 months ago #

    That would be perfect mate, I understand what you're saying about WordPress being framework and needs to be used properly, But for some people, even for myself, sometimes it's just easier and faster to upload image I want to use for CSS through media uploader and then use /wp-content/uplods/file-name.jpg in stylesheet as url for background for example.

    Anyway, still loving your work!

  11. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    yes you are right so I need to implement it. thank you so much...

  12. Kramarz
    Member
    Posted 4 months ago #

    Hi again Emre :-(

    Please take a look at http://www.irishrecycledproducts.ie/

    Down the bottom right there are social icons appearing just fine on home page, but when you go to any other page and check the display is broken.

    Any ideas? Could be a conflict with Simple Social Icons plugin? Was fine before latest update as far as I know.

  13. Kramarz
    Member
    Posted 4 months ago #

    ok, update - looks like you still need to do some work on combining stylesheet option

    When I don't use:

    Combine Css - (Beta)Reduce HTTP requests through combined files

    Everything is fine.

  14. Kramarz
    Member
    Posted 4 months ago #

    I will leave it broken for you to inspect until I hear from you or till tomorrow, whichever comes first :-)

    Thanks!

  15. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    "Combine Css" is beta now. I am working on making it compatible on all platforms.

  16. Kramarz
    Member
    Posted 4 months ago #

    Ok, I'm going to switch it off now then, until further notice! :-)

    Thanks and all the best!

  17. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    Hi again Kramarz, I fixed the issue. Can you do the steps below please?

    - Deactive the plugin
    - Remove the plugin
    - Download the plugin again
    - Re-install

    and Can you inform me after testing please?

  18. Kramarz
    Member
    Posted 4 months ago #

    [EDIT] nvm, see below

  19. Kramarz
    Member
    Posted 4 months ago #

    Which one did you fix - 'Combine CSS' problem or relative paths issue?

  20. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    I fixed both of them. Can you try it and inform me please?

  21. Kramarz
    Member
    Posted 4 months ago #

    Combining CSS seems to be working fine now indeed :-)

    And relative paths, looks like it works as well now. I got a little glitch there for some reason, but it's a bug in theme not your plugin.

    So, nice work mate!

    Thank you! :-)

  22. Kramarz
    Member
    Posted 4 months ago #

    Oh, one thing that I noticed, folders in 'cache' folder don't get deleted with plugin uninstalling, is that how it should be?

  23. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    yes, when the plugin is deactiveted, "cache" foles is not removed...
    what's the problem? is there is any problem about css minify/combine or path?

  24. Kramarz
    Member
    Posted 4 months ago #

    nah, it's just that one of the themes I used has some styling done through script or something, and if I don't use a background image for one of the widgets, css for it looks like this:

    background: url("");

    and your plugin makes it a broken img link, like that:

    background: url("http://www.website.com/wp-content/themes/theme/");

    Nothing you can do about it :-)

    So again, good job!

  25. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    your welcome. you can vote :)

  26. Emre Vona
    Member
    Plugin Author

    Posted 4 months ago #

    Kramarz, this is not your fault. Anymore background: url("") is not modified. I fixed it.
    You can try it

    - Deactive the plugin
    - Remove the plugin
    - Remove /wp-content/cache/
    - Download the plugin again
    - Re-install

  27. Kramarz
    Member
    Posted 4 months ago #

    5 stars!
    Next I will try to use your plugin with one of the woocommerce websites!

  28. Kramarz
    Member
    Posted 4 months ago #

    Yay! \o/

    url("") issue fixed indeed!

    All the best mate!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.