WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Minify combined outputs wrong URL for subdirectory install (4 posts)

  1. hardigi
    Member
    Posted 11 months ago #

    Hi

    I am running WordPress in a subdirectory at http://www.website.com/wordpress/

    Minify JS is outputting the wrong URL for the combined javascript file in the head of the document.

    W3TC outputs:
    http://www.website.com/wordpress/\wordpress/wp-content/...

    It should be outputting:
    http://www.website.com/wordpress/wp-content/...

    Any ideas on why this is happening and how to fix it?

    (I am running Windows 2008 server and IIS 7)

    Thanks!

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. ebenchich
    Member
    Posted 11 months ago #

    If I had to guess, your WordPress and Site address are both http://www.website.com/wordpress/ in your General Settings.

    Take a look at http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory to see how to fix the subdirectory issue.

  3. hardigi
    Member
    Posted 11 months ago #

    Thanks for the suggestion Ebenchich.

    I don't think this applies to me though because I am running the site from the subdirectory as well (not the root). The rest of my site is powered by Coldfusion - it is just the one directory (in the original post called /wordpress/) which is running wordpress.

    I am guessing there is something in the W3 Total Cache plugin php which I need to modify to allow for this. Unfortunately I don't know how!

  4. hardigi
    Member
    Posted 6 months ago #

    Found a work around.

Reply

You must log in to post.

About this Plugin

About this Topic