WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Minify broken in latest update (22 posts)

  1. viptampa
    Member
    Posted 3 years ago #

    Updated both WP and W3 total cache... minify of JS files seems to go crazy. Disabling minify seems to work... but sucks that I have to use additional plugins to do the samething.

  2. Shyzer
    Member
    Posted 3 years ago #

    I was having the exact same issue after upgrading. However I think I fixed it by deleting a .js that didn't exist anymore. It was from a plugin that I deleted last week and I'd forgotten to take the code out of my minify section.

  3. viptampa
    Member
    Posted 3 years ago #

    Well, I set minify to manual an one by one verified each and every js script. All of them exist. I think that some of them can't be minified though.
    I disabled minify in the w3 total cache and just used another plugin. (wp minify)

    The problem with that is that the cdn portion of w3 total cache doesn't use the minified files from wp minify.

    I might try to find which scripts are failing to stay with w3 total cache, but I think Frederick has a lot of work ahead to keep w3 total cache ahead of the pack.

  4. John Saddington
    Member
    Posted 3 years ago #

    i'm having a slightly similar issue.

    http://cl.ly/7v4t

    despite the fact that all the js and css files are there it still is prompting warnings. anyone else seeing the warnings despite verifying js/css minification?

  5. kfawcett
    Member
    Posted 3 years ago #

    @tentblogger

    I came across your problem too. For some reason something in the array for the minify settings has gotten messed up in the config file.

    If you open your configuration file named "w3-total-cache-config-yoursitename.php" you will see a section for minify.css and minify.js

    In there will be some arrays that should have locations of your minified files.

    Make sure to disable Minify. Then delete only the arrays as shown below. Be careful not to delete anything else -- like the beggining/ending array tags.

    'c5082' => array(
    			'default' => array(
    				'include' => array(
    					'files' => array(
    						0 => 'wp-content/themes/mysite/style.css',
    						1 => 'wp-content/themes/mysite/js/colorbox/colorbox.css',
    						2 => 'wp-content/themes/mysite/skins/blue.css',
    						3 => 'wp-content/themes/mysite/custom.css',
    						4 => '/wp-content/plugins/sidebar-login/style.css?ver=3.1.3',
    					),
    				),
    			),
    		),

    You should be left with these for each group.

    'minify.css.groups' => array( ),
    'minify.js.groups' => array( ),

    Then go back and re-add your files and enable minify. That should fix your problem.

  6. John Saddington
    Member
    Posted 3 years ago #

    is this file in the plugin folder directly or at the root of wp-content?

  7. kfawcett
    Member
    Posted 3 years ago #

    In wp-content

  8. viptampa
    Member
    Posted 3 years ago #

    I'll try the fix tonight and report back.
    Thanks again for trying to help out.

  9. John Saddington
    Member
    Posted 3 years ago #

    sweet! thanks.

  10. viptampa
    Member
    Posted 3 years ago #

    Hmm, seems to make it worse :(

    Literally added multiple js scripts to one line separating them by comas.
    sigh...

    Any other suggestions?

  11. viptampa
    Member
    Posted 3 years ago #

    sigh...

    thats odd... manual doesn't work... but if I set minify to automatic (now that I cleared out the file as kfawcett mentioned, my JS is working. :)

    thanks again!

  12. viptampa
    Member
    Posted 3 years ago #

    Fook...

    well, so much for that success. W3 minify is still messing up. A JS for my theme isn't working.

  13. kfawcett
    Member
    Posted 3 years ago #

    Are you running 9.2.3? If so, then you went into the config file, deleted the files in the array, then went back and re-added the files through the help wizard or manually. Once all that was done you re-enabled minify?

  14. kfawcett
    Member
    Posted 3 years ago #

    Not all files can be minified, especially JS files. A lot of time if the JS file is compressed it could end up corrupting the file due to the JS code not being written correctly.

  15. viptampa
    Member
    Posted 3 years ago #

    Yep, I'm running the latest version of W3.

    Yea, I had delete the config file and start over.

    I had to eliminate a lot of JS files that could not be minified.
    My media player for one and 2 scripts for the ui on my wp site were just a few of those.

    My site 'seems' be back to normal... but sucks that I had to even have to manually do this as WP Minify does it w/o intervention. At least I know my minify files are going to my CDN.

  16. kfawcett
    Member
    Posted 3 years ago #

    Yeah, W3TC usually does it without intervention also, but it's an extremely complicated plugin that has been designed to work across multiple system configurations. The author has put tons of time into it and sometimes it takes a little extra user intervention to configure it for your specific system.

  17. viptampa
    Member
    Posted 3 years ago #

    I just don't understand WHY it worked fine with the previous version (no glitches) but with this version... more than just a few are having problems with minify.

  18. kfawcett
    Member
    Posted 3 years ago #

    Yeah, it appears that a lot of extra features have been added since the 9.1.x releases and with that comes extra complexities. With a plugin as complicated as W3TC you cannot test every possibility, especially when you are giving the plugin away for free. Unfortunately that leaves us, as users, to help with identifying bugs and helping to improve the plugin.

    If you're not comfortable with doing that, then the best option would be to stay with an older version of a plugin and wait a longer period before updating. This is how most larger corporations work too -- They are usually never first adopters because there are almost always bugs.

  19. viptampa
    Member
    Posted 3 years ago #

    I don't mind bugs... but I do mind being told by the author... 'just disable it.'

    I don't like being told that it's a server issue when obviously it's not. I don't mind troubleshooting if someone can give me some breadcrumbs (like you have).

    But like I said... W3TC minify no longer works automatically for me and obviously others.

    sigh... and I'm still getting "Recently an error occurred while creating the CSS / JS minify cache: Some files were unavailable, please check the settings to ensure the site is working as intended"

    I've verified manually every JS file and CS file that minify is touching... and they all exist.

  20. viptampa
    Member
    Posted 3 years ago #

    Sigh, your suggestion does not work.

    I've cleared the array like you mentioned 3x and it still gets errors when I add files to it... ANY files.

    I'm moving to WP Minify. W3TC needs to get its minifying core back from the last version.

  21. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I don't recall saying it's a server issue. Disabling an option temporarily is far better than nothing. I don't understand what the problem is, I've been working for years to help everyone, that's clearly is not going to change.

    It's also impossible to explain to users before updating or even in the forums WHY issues occur. WP Minify does not scale and does not optimize like W3TC, what was added in recent release is auto-minification that DOES scale and does optimize better, that is extremely difficult to do, which is why no one did it before.

    In the end, the software is not a final release and it's the fault of the software that it doesn't make things easy on you, which is why there are some really great people trying to help everyone proceed.

    If anyone's still having issues, please submit a bug submission form from the support tab of the plugin.

  22. scottdaris
    Member
    Posted 2 years ago #

    I don't know if this applies, but see my post about automatic minifying errors:
    http://wordpress.org/support/topic/plugin-w3-total-cache-important-parsing-found-with-automatic-minify
    (btw, I meant to say *Important* parsing error found with automatic minify)
    In the minifying process, incorrect .js code was generated. You'll see what I mean in my post. Good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic